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Skills covered in this tutorial include:
•
•
•
•

Obtaining excel data from the American Fact Finder on Census.Gov
Obtaining Geography Data from census.gov
Cleaning Excel Data for Joins
Joining Excel Data in ArcMap

In this tutorial, we will be obtaining information about housing tenure at the Census Tract level from the
2010 Census for a single county using American Factfinder. You can then use a similar process to download
any other Census 2010, American Community Survey, or Census 2000 data for other geography levels
and/or for whole states or multiple counties. You have many, many options in American Factfinder – this
shows one possible path.

Obtaining GIS Files from Census Geography
The first step is to download the administrative geography spatial data (shapefiles) from Census.gov. This is the GIS
data and contains only the boundary data – there is no demographic information included.
1. Data management is critical when dealing with the multiple tables of the Census. Before beginning
this tutorial:
a. Create a “Census_2010” folder in your personal workspace (H drive).
b. Create two subfolders: AFF_Data and Census_Geography
•

The AFF folder will hold the excel tables you download from the Census
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•

The Geography folder will hold the actual GIS Data shapefiles

2. Go to the Census web site (http://census.gov) and click Browse by Topic and then the Geography link.

3. Under Maps and Data, select TIGER Products.

4. Then click on Tiger/Line Shapefiles in the Table as shown:

5. Click on 2017 and expand Download tab. Then click on Web Interface.
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6. Under Select Year, choose 2017 and under Select a Layer Type, notice how many different types
of GIS data you can download from here! Remember this site!! Choose Census Tracts then
Submit.

7. Select your state of interest (this tutorial will use Massachusetts data, but feel free to try it with
your own area of interest if you wish!) and click download. It downloads the data as a zipped
file.
8. Save the zip file into the Census_Geography folder in your H drive. Navigate to the folder (in
windows) and right click on the zipped file. Select extract here.
9. Open a blank ArcMap session and navigate to that folder in Catalog. Drag in this new shapefile
from your H drive. If you already had ArcMap open, you’ll likely have to refresh your H drive
folder.

10. Change the name of the layer in the Table of Contents from tl_2017_25_tract to Census Tracts.
The census naming system for this particular files works as such: tl =tiger, 2017 is the year the
data represents, 25 is the state number –aka Mass, and Tract is the unit of the administrative
boundary.
Remember: Census tracts are created to have approximately 4000 people per census tract – that
is why they are varying sizes across the state.

Obtaining Data from American FactFinder (AFF)
Now we need to go and get the excel data containing all the demographic data per census tract.
1. Go to the US Census web site – http://census.gov
2. Click on the Data tab → Data Tools & Apps → select American FactFinder. This is the web interface to access
census excel/tabular data.
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3. Click on Advanced Search and select Show Me All.

4. Click on Geographies in the left column – this brings up the Select Geographies overlay. This is where we tell it
to get Mass data ONLY by census tract! Once we set this search selection, the census website will only give us
data that is available for this location and scale.
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5. Fill out the box so that you are selecting Census Tracts for a specific state and a county in that state. You can
follow the example below if you want to select all census tracts in Suffolk County, Massachusetts.
Alternatively, you could pick a state and county of your choosing.

6. Be sure to click on ADD TO YOUR SELECTIONS.
7. Close the Select Geographies overlay by clicking in the top right corner of the box.
8. Now that you told it where you want the data, you need to tell it WHAT data you want to download. Today,
you’ll be downloading information on Housing and Tenure.
9. Click on Topics in the left column and expand Dataset.
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10. Scroll down to click on 2010 SF1 100% Data – this will send this criteria to your Selection box in the upper left
of the site:

11. Scroll up in the Topics list and click on Housing. Then, under Occupancy Characteristic, click on
Owner/Renter (Tenure in Occupied Units).

12. Close the Topics box by clicking in the top right corner of the box.
13. Be sure that the Your Selections box in the upper left corner contains what you want – the data set, the
general topic, and the census geography level for the specific location you want (all tracts, not just one
tract). If it does not say this, clear your selections and start over from Step 4 above.

14. You should now have a list of available datasets about housing characteristics. Checkmark one of interest
and see what variables it contains by clicking on the Information icon for that table.
This pulls up the
information about this table. You’ll see what data will be included when you download it. This is very
helpful for previewing datasets so you don’t have to go through all the steps of downloading it first. For this
exercise, we highly recommend a table with just a few variables. In this exercise, we have used the H11
table for total population in occupied housing.
15. After checking a table, click on Download (
file. Save it in your Census_2010 →AFF Data folder.

) and follow the instructions. This creates a zip
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16. Navigate to your AFF folder. Right click on the zipped folder and select extract here or open with Power
Archiver and extract to AFF folder.

Preparing American FactFinder Data for Use in ArcMap
1. You’ll notice that 2 csv files have downloaded, along with two txt files. Double-click on both downloaded
CSV files to open them:

Several files will be downloaded. The “with_ann” file contains the data, while the “metadata” file contains
the descriptions of the table headings. Open both excel files. Note: If you are opening the file from within
Excel, you will need to set the option to look for all file types
Note: If you are opening the file from within Excel, you will need to set the option to look for all file types:
2.

The “DEC_10…with_ann” file should look something like this.

This file contains the data and the headings. Notice how there are essentially two headings. The first row
contains “Data Speak” and the one below contains written out explanations.
3. Now look at the “DEC_10… _metadata” file. This file explains the column header codes in the data file - it
should look something like what you see below. This is a very important file!!!
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Typically the first data column (D001 here) is the Universe of things counted in this table. This table is
counting people in occupied housing units. If you wanted to show the % of the population that is in rented
housing units, you would divide D004 by D001 and multiply by 100. This process is called “normalizing.”
A few important steps left.
Go back to the excel file containing the data. Now we need to clean it EXTENSIVELY so that we can
join it in ArcMap. ArcMap is VERY picky about how data is formatted!!! Make sure to follow all rules
below:
1. The very top row (with all the data speak headings) will be our Attribute table headings. ArcGIS
does not like ANY extra characters in the column names. Delete all periods (.) and extra
characters (-) in all the column names/heading. The only acceptable character is underscores (_).
2. In ArcMap, open the census tracts attribute table. Find the GeoID field heading. Right click on it and
open the properties. You will notice that it says it’s a string. String means that it is formatted as text
(not a number). It needs to be formatted as text so GeoIDs that start or end with a 0 don’t get
adjusted to drop the 0 (for example, zip codes like 02144 don’t get automatically changed to 2144).

3. Since our joins need to have fields that match EXACTLY, both the excel data field and the attribute table field
that will be matched (joined) need to both be strings/text.
4. Back in excel, notice the GEOid2 field. This is the field that exactly matches what is in the census tracts
attribute table. However, we can’t really tell right now because it’s formatted as a number and therefore
changes the number to read as 2.5E+10. As a result, this field must be changed to text for the join to work
properly. Follow the image below…
a) Highlight the GEOid2 column.
b) On the Excel toolbar at the top, click on the Data tab
c) Click on Text to Columns:

d) Click Next to leave the first setting at Delimited.
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e) Click Next to leave the second setting at Tab.
f)

In Step 3, change the column data format to TEXT, and then hit Finish. This will format ONLY
THIS ONE COLUMN as text (because we still want all the data itself to be a “number”).

3. Notice now how all the numbers in GeoID2 now look identical to how the GEOID field is formatted in
ArcMap. We’re getting closer.
4. Census.gov now includes the description of the column under the column heading in the excel sheet
(e.g. Under D001 it says Total Population). However, ArcMap does not like this extra row and the text
causes the software to read it as a “string” (e.g. text) instead of “double” (e.g. numbers). Therefore, it
is necessary to delete this row so that ArcMap realizes that this is a number field and not a text field.

Optional Tip – Although you need to delete the 2nd row of text, you can change the column headings
to the descriptions if it makes it easier (e.g. Change D001 to Tot_Pop). However, there can be no
spaces or periods and the heading needs to be under 9 characters. For excel sheets containing several
fields, it’s probably easier to refer to the codes later rather than changing all the column headings.
5. To make things easier later, rename the worksheet to something comprehensible, e.g.,
Housing_Tenure - the worksheet name will be the identifier in ArcCatalog.

6. Very important step – save your modified CSV file as an Excel Workbook (.xlsx) – give it a
comprehensible name, e.g., 2010CensusH11_populationbyhousingtenure.xlsx. Save it in your H Drive
Aff_Data Folder
Note: Your table may have columns where the data has text values in it. For example, column D001
(which is total population) has data like 4225(r33818) or 3730(r33819). Since ArcMap uses the first
eight rows to determine what the data type is for each column (ex: string, float, double, integer, etc.),
it is necessary to delete the information in parentheses for it to be mappable as a number.
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7. Extra step for Alaska, Alabama, Arkansas, Arizona, California, Colorado, and Connecticut. (Ignore
this section if you are not working in these states)
Some states have FIPS codes that start with a zero, and because Excel removes that leading zero, the table
won't join properly unless we put it back on. If you're working in Alaska, Alabama, Arkansas, Arizona,
California, Colorado, or Connecticut, you'll have to add that zero back on manually. To add the zero back on,
create a new column next to GEOid2, in Row2 type in: =concatenate(“0”,C2).

Hit Enter. If the result of that formula looks right (i.e. it has a leading zero), copy that cell’s formula to the
rest of the column.
You're almost done! To keep this compatible with the rest of the directions, copy all of the cells in this new
column, and right click on the GEOid2 column. Click the options below “Paste Special”, choose Values, and
your leading zeroes should be all set. Ensure your column is still named GeoID2.
Delete the column you added but be sure you still have the fixed GeoID2 column. Save the file!

Final STEP: Save your file and EXIT out of Excel – you CANNOT have Excel open still when
you work with this data in ArcGIS!
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Now you’re ready for mapping!

Joining the AFF table to your Census Tract polygons in ArcMap
1. In ArcMap, open the Census Tracts polygon attribute table and take a look at it.
2. Which column matches the excel document EXACTLY? The GeoID in the attribute table matches the GeoID2
from the excel table exactly! Therefore, we will use the GeoID column to join our AFF data. Remember
from class, that GeoID is a concatenation of the State FIPS Code (25 for Mass) plus the County FIPS Code
plus the Tract FIPS code. Every single tract in the US has a unique ID! This unique ID is the best way to
identify counties, especially since many different states contain counties with the same names.
3. Right-click on GEOID field name and choose Properties. You’ll see it is a string type attribute field – that’s
important to know. Strings are the same as “text”, which is why we changed GeoID2 to “text” in excel!
Close the table.

4. In Catalog, add your census excel sheet to the map. If you don’t see it in Catalog, refresh the folder by rightclicking it and selecting “Refresh”. You will need to drill down to the sheet level, as shown below. If there is still
a plus sign, you haven’t gone deep enough! Drag the “Housing_Tenure$” sheet into your map like you would a
shapefile.

5. If you get the following error, it means that your version of ArcGIS and Excel are having connectivity issues.
A solution may be to save your Housing Tenure excel sheet as an Excel 97-2003 Workbook (*.xls) or CSV.

6. In the Table of Contents, open Housing_Tenure Table by right-clicking on it and choosing Open- very similar
to how you would open an attribute table.
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GEOID2 will be used to join this AFF data to the 2017 Census Geography. These two fields match exactly. It’s
OK that they have different names. Check its properties to ensure that it is also a STRING type, close the
table when done.
Take a second to realize that you will not being joining the GeoID to GeoID. You will instead be joining
GeoID2 (from the Housing_Tenure$ table) to GeoID in the Census Tracts shapefile.
7. Right click on the GeoID2 field → Properties, and double check that the type is indeed a String. If it says
double, you did not convert it to text in excel and must go back and redo that step (Page 8, step 4). That’s
why I had you check twice. If it says string, you are good to proceed! Close the attribute table.
8. Right click on your Census Tracts and choose Join & Relates, then select Join…
9. Fill in the dialog box as follows. You are joining attributes from a table (the spreadsheet, in this case
Housing_Tenure$) using GEOID in your Census Tracts layer and GEOid2 in your Excel table. Click OK when
done:
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Note: By clicking “Keep only matching records”, only Suffolk County will remain visible in the shapefile
because we only downloaded census tabular data for this one county in MA. If we select “Keep all records”,
MA would remain whole, however, the attribute table would only have housing information for the census
tracts within Suffolk County. The rest of the census tracts would read “Null” in those joined fields.
10. Open Census Tracts attribute table to ensure that the join was made correctly. If so, you should see your
housing tenure AFF data when you scroll to the right in the table. Close the table.
11. It is important to know that when you make a join it is not permanent until you EXPORT THE DATA. Until
you export, the join is only temporary. If you run any tools on this layer without exporting the data, it will
drop the joined data. Exporting the data saves this shapefile as a NEW shapefile, where the join is now
permanently part of the attribute table.
Export the data by right clicking on the census tracts, selecting Data and then Export Data.

12. Save the shapefile with an appropriate name inside the Geography folder (include Census tracts so you know
the boundaries and include the location). It can be good to acknowledge exactly what has been joined,
especially if you end up having multiple joined layers. Also, make sure to save as a shapefile, otherwise you
will encounter an error.
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13. Exporting data is always good practice to ensure something is permanent. It also sometimes resolves minor
ArcGIS glitches, such as layers not drawing on the map.
14. Now before hitting OK you will need to decide if you want to save this new shapefile to the coordinate
system it came with (2016 Census Data uses GCS_North_American_1983), or if you have already put the data
frame into a certain projection you could select data frame (this map ultimately uses
NAD_1983_StatePlane_Massachusetts_Mainland_FIPS_2001). By setting your data frame projection first,
this then saves you the step of projecting your data later!
15. Press ok and click yes when asked if you want to add the exported the data to the map as a layer. Now, you
should see a new layer in the Table of Contents with your given name. It has also been added to the Catalog!

16. Since you have saved this join as new shapefile, you can remove the join from the original Census Tracts
Shapefile. Right click on Census Tracts, and click Joins and Relates and then Remove Join(s) →
Housing_Tenure$.

17. When you do this it removes the excel data in the Census Tracts attribute table, and the shapefile reverts
back to all of Massachusetts. The reason why you would want to remove the join is so you can join a new or
different tabular dataset to this shapefile without having to download it again from the census.
18. After you remove the join from the original Census Tracts layer, turn the layer off. You are done working with
this one.
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Removing Water Only Census Tracts
If your area of interest is near water or has water features in it (like Boston), your census tract data will extend
into the water. Why? Because people live on islands and on boats, and census tracts includes those areas!
However, we don’t always want to map them, so let’s remove them.

1. To get rid of the water tracts from your new shapefile, right-click it and open the layer Properties, and click on the
Symbology tab.
2. Click on Quantities.
3. Under Value, choose the variable D001 (or Tot_Pop if you renamed it in excel first).
4. Then click on Classify.
5. In the Classify dialog box, click on Exclusion. You can exclude all census tracts where the land area is equal to
0 (no land, only water), and hit OK. This process is shown in steps 6-9 depicted below:

6. Now you can map your data without having to include water-based census tracts. If you are unfamiliar with
mapping numeric values using symbology, see the ArcGIS 10.2 online help – About Symbolizing Layers to
Represent Quantity.
Note: Do not just accept the default colors. Play around with the different color schemes!
7. Your data is ready to map. Make sure to save often!
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Setting a Projected Coordinate System for your Map
It is always necessary to put your map into an appropriate projected coordinate system. The TIGER data is in a
geographic coordinate system (GCS) and can appear distorted on your map. You can fix this problem by setting a
projected coordinate system appropriate for your region.
You will need to know the best coordinate system to use for your area of interest. In the case of Massachusetts, we
will use the Massachusetts State Plane (NAD83) – meters coordinate system. If you don’t know which coordinate
system to use, use this resource. It is a quick read that gives you an understanding of what factors to consider when
selecting a projection, and provides a helpful table at the end.
1. Click on View → Data Frame Properties.
2. Click on the Coordinate System tab.
3. Scroll down till you find the Projected Coordinate Systems folder. Make sure you are not still in the
“Geographic Coordinate System” folder.
4. Scroll down to the State Plane folder – open that folder and select NAD 1983 (Meters) from the list:

5. Find NAD 1983 StatePlane Massachuestts Mainland (not Isl which means Islands) and click on it:

6. Click OK and click Yes when warned that the coordinate system is different from the data in your maps.
You’re done! You have successfully downloaded American Fact Finder data (AFF) and joined it to Census Geography
data in ArcMap. The process of finding and preparing data can be time consuming, but doing it correctly is
important to ensure that your maps and the information they are conveying is accurate.
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Using Symbology to Map a Demographic Variable
Now that our join is successful, we want to use symbology to show one of our demographic variables by census
tract. Let’s open up the attribute table of the Suffolk_CensusTracts_HousingTenure layer to remember what our
options are for the demographic variables on tenure.
1. Let’s map the D004 variable (Renter Occupied). If we were to symbolize this variable, it would just be a raw
count of the population living in renter-occupied housing units. Instead, we want to show a percent so that
we can better compare between census tracts and better understand what the data means. This is called
normalizing. It is very important when analyzing any dataset.
2. In order to make this number a percent, we must divide the population of renter-occupied housing units
(D004) by the Total population in occupied housing units (D001).
3. Double click on your new shapefile Suffolk_CensusTracts_HousingTenure to get to the properties. Then click
on the Symbology tab.
4. Since we want to map numbers select Quantities on the left hand side of the symbology box.
5. The Value field dropdown contains all the Attribute Table headings. Let’s select D004 or the variable that
represents population of renter-occupied housing units (below it has been relabeled to Renter_Occ). Hit
Apply – the map updates, even though the property box remains open. You can move the Property box out
of the way to see the map! See below for an example of how to change the symbology.

Note: As it stands, the map is NOT illustrating a percentage of the population living in renter-occupied
housing units. This is just the raw count of the population living in renter occupied households. It is not
useful for comparisons, since census tracts are varying sizes.
6. In order to compare values between census tracts, we must turn this number into a percent. This means
taking the total population living in renter occupied households and dividing it by the TOTAL POPULATION in
occupied housing units. This process is called Normalizing and it is an important statistical operation that
allows comparison of two different sized areas.
7. To do this, we select the Normalization field in symbology. We know that D001 is the field containing data
for the total population in occupied housing units. If you changed field labels, you may have a field titled
TotalPop or something similar instead. Change the normalization field to D001 or TotalPop.
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8. Click Apply. Notice how the map changes. Also, the numbers changed under the Label column. Now they are
fractions representing population of renter-occupied housing units divided by total population of occupied
housing units. To format the labels to show percentage, we must multiply them by 100.

9. ArcMap makes it easy to format numbers. Click on Label → Format Labels…
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10. There are already a bunch of different number categories. Since we want to convert the fractions to
percentage, click on Percentage on the left. Now, two options appear. Since the numbers currently represent
a fraction, and we want to adjust it to show a percentage, select the 2nd option. Now, ArcMap will
automatically multiply our numbers by 100 without us having to do anything!

11. If you hit OK now, our numbers will be in percentage, but they will have a lot of decimal places that make it
hard to read. If you have hit OK, go back to the Number Format properties (click on Label > Format Labels >
Percentage). In the Number Format box under Percentage, click Numeric Option.
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12. This opens up another box, which allows us to choose the number of decimal places or significant digits. Let’s
limit our labels to 1 decimal place.

13. Now press OK, then OK, then Apply. Now our numbers are MUCH more simplified and easier to read.
14. Pick a gradual color scheme (light to dark) that you like in the Color Ramp. Press apply to see how the
different colors look. Find one you like, and close the Layer Properties window by clicking OK.
15. Lastly, let’s change the layer name and heading in the table of contents so that when we add our legend it
looks good! Change the name of Suffolk_CensusTracts_HousingTenure to Census Tracts. Then change the
heading name to % Renter-Occupied Households.

16. Save your map.
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Adding Base Map Data
Our map is coming along nicely, but for the final product, we should add some other data so it does not appear that
Boston is floating in the middle of nowhere! We are going to pull in the Census Towns polygons from the M drive.
1. In Catalog, open the M drive.
2. Navigate to State → MA →MassGIS → Census_2010 → CENSUS2010TOWNS.gbd → CENSUS2010TOWNS_POLY

3. Pull in CENSUS2010TOWNS_POLY. This is the Census Towns polygons layer.
4. Change the name of CENSUS2010TOWNS_POLY to Towns and drag it underneath your census tracts and change
the color to make it a neutral background color – either a very light yellow or light gray. That way, it does not
draw a lot of attention.
5. Now, the only thing missing is to turn the water blue! We could find a water layer and pull it in, or we can use a
very helpful shortcut! Double click on the Data Frame (aka Layers) or go to View → Data Frame Properties.
6. Click on the Frame tab and change the Background color to a blue. Press OK. Disregard the error about
coordinate systems (at least for this week).
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Disclaimer: If the map projection changes when you change your background color to blue (you will know
because the map will seem to spread out horizontally), go back and set the projection under the Coordinate
System tab. See “Setting a Projected Coordinate System for your Map” section on page 18. Note, this should not
happen and likely will not.
7. Voila! Now our water is blue.

Creating a Map Layout
1. Switch to Layout View so we’re setting up our piece of paper.
2. You’ll likely want to switch your paper to landscape, which is done in the File → page and print setup.
3. Set up the Data Frame on the piece of paper how you would like it arranged. Then, zoom into Suffolk County so
it fills out the whole data frame area really well.
4. Time to add some labels. Go to Customize → Toolbars and select the Draw toolbar. This toolbar is VERY handy!
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5. Next to the A, click the little down arrow and select Label. This allows you to label individual features and pulls
the info from the attribute table. We will label the surrounding towns. If label is greyed out, double click on the
data frame using the pointer arrow to get the slashes and activate it.

6. In the Label Tool Options window that appears, click Place label at position clicked. Now click inside Brookline.
You will see it adds a label wherever you clicked. You can move these labels easily by clicking on them and
moving them.
7. Add a label for other surrounding cities.
8. One thing you might notice is that they are so tiny. Click the select arrow on the toolbar. Then hold down the
Ctrl button and click each label. This will select them all at once.
9. On the draw toolbar, you can now use the font drop down and size drop down to make them bigger and bold.
One thing that looks really nice is to give the state labels a bit of character spacing. When they are all
highlighted, choose your font and size. Then, right click on one of the labels→ properties. Change the Character
Spacing to 30.
10. Let’s also change the color of the font to a grey, so the black isn’t so aggressive and the first thing you notice.
These labels should fall into the background.
11. Now, move forward with putting in the rest of the map elements as you learned in the ArcGIS Basics tutorial
(title, legend, scale, bar and data citation text/date).
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Check out the example map below:
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