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In this tutorial, we will be obtaining information about Health Insurance Coverage Status by Sex and Age
the Census Tract level from the 2010 Census for Massachusetts using American Factfinder. You can then
use a similar process to download any other Census 2010, American Community Survey, or Census 2000
data for other geography levels and/or for whole states or multiple counties. You have many, many options
in American Factfinder – this shows one possible path.

Obtaining GIS files from Census Geography
The first step is to download the administrative geography spatial data (shapefiles) from Census.Gov. This is the GIS
data and only contains the boundary data – there is no demographic information included.
1. Data management is critical when dealing with the multiple tables from the Census. Before
beginning this tutorial:
• In your H Drive → Week 3 Folder, create a new folder and call it “Census_2010”
• Create two subfolders: AFF_Data and Census_Geography
•

The AFF folder will hold the excel tables you download from the Census

•

The Geography folder will hold that actual GIS Data Shapefiles

2. Go to the Census web site (https://www.census.gov/) and click on Browse by Topic tab at the top and
Geography.
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3. Under Geographic Data (bottom right), select TIGER Products.

4. Click on 2018 and then click on Web Interface.

5. Under Select Year, choose 2018 and under Select a Layer Type, notice how many different types of GIS data
you can download from here! Remember this site!! Choose Census Tracts then Submit.
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6. Select your State of interest (this tutorial will use Massachusetts data, but feel free to try it with your own
area of interest if you wish!) and click download. It downloads the data as a zipped file.
7. Save the zip file into the Census_Geography folder in your H drive. Navigate to the folder (in windows) and
right click on the zipped file. Select extract here.
8. Open a blank ArcMap session and navigate to that folder in Catalog. Drag in this new shapefile from your H
drive. If you already had ArcMap open, you’ll likely have to refresh your H drive folder.
9. Change the name of the layer in the Table of Contents from tl_2018_25_tract to Census Tracts.
Remember: Census tracts are created to have approximately 4000 people per census tract – that is why
they are varying sizes across the state.

Obtaining Tabular Data from American FactFinder (AFF)
Now we need to go and get the excel data containing all the demographic data per census tract.
1. Go back to the US Census web site – https://www.census.gov/. Click on the Explore Data tab →
Data Tools & Apps.

2. Scroll down and select American FactFinder. This is the web interface to access census excel/tabular data.
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3. Click on Advanced Search and select Show Me All.

4. Click on Geographies in the left column – this brings up the Select Geographies overlay. This is where
we tell it to get Mass data ONLY by census tract! Once we set this search selection, the census website
will only give us data that is available for this location and scale.
5. Fill out the box so that you are selecting Census Tracts for a specific state and a county in that state.
You can follow the example below if you want to select all census tracts in Massachusetts.
Alternatively, you could pick a state of your choosing.

6. Be sure to click on ADD TO YOUR SELECTIONS.
7. Close the Select Geographies overlay.
8. Now that you told it where you want the data, now we need to tell it WHAT data we want to download.
Today, we’ll be downloading information on Health Insurance coverage.
9. In the Refine your search results: section at the top, search Health in the topic or table name field. Then
press Go.
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10. You’ll see 4 tables starred at the top – all of which are suggested results about health. The tables below also
cover a variety of health information.

11. Press the I next to the “Health Insurance Coverage by Sex by Age”. This pulls up the information about this
table. You’ll see what data will be included when you download it. This is very helpful for previewing
datasets so you don’t have to go through all the steps of downloading it first.

12. Also, note the DATE this data represents. This table is from the 2017 American Community Survey (ACS) 5
year estimates. Therefore it is a sample of the population, not a full count as done in 2000 or 2010.
13. Check the square to the left of the ID number for this table. Make sure it is ID B27001. Press Download.
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14. Save this new zipped file into your H drive → AFF_Data folder and then unzip it.

Preparing American Factfinder Excel Data for Use in ArcMap
1. You’ll notice that 2 csv files have downloaded, along with two txt files. Double click on the
ACS_17_5YR_B27001.txt file and read the overview of this dataset. Make sure to note the universe.

2. In your windows folder, double-click on both downloaded CSV excel files to open them:
Several files will be downloaded. The “with_ann” file contains the data, while the “metadata” file contains
the descriptions of the table headings. Open both excel files.
Note: If you are opening the file from within Excel, you will need to set the option to look for all file types.
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3. The “ACS_17_5YR_B27001_with_ann” file should look something like this.

This file contains the data and the headings. Notice how there are essentially two headings. One with “Data
Speak” and the other with written out explanations.
4. Now look at the “ACS_15_5YR_B27001_metadata” file. This file explains the Field Header codes in the data
file - it should look something like what you see below. This is a very important file!! Look through all the
Data that this excel data provides! This table is LONG! There is a lot of info!!
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Typically the first data column (HD01_VD01 here) is the Universe of things counted in this table. We know
from the txt document that the universe is non-institutionalized people. Not necessarily ALL people. This is
an important distinction. If you look at the count of people of age 18 – 24 who have no health insurance, this
is only counting those that are not institutionalized.
A few important steps left.
1. Go back to the excel file containing the data. Now we need to clean it EXTENSIVELY so that we
can join it in ArcMap. ArcMap is VERY picky about how data is formatted!!! Make sure to follow
all rules below:
2. The very top row (with all the data speak headings) will be our Attribute table headings. ArcMap
does not like extra characters in the field names. Delete all periods (.) and extra characters (-) in
all the column names. It ONLY likes underscores (_). You will likely only need to change columns
A, B, C. The rest of the headings follow these rules, that’s why they are so cryptic and that’s
why the 2nd excel sheet that tells us what all the headers mean is SO important!!
3. In ArcMap, open the attribute table of the census tracts. Find the GeoID field heading. Right click on
it and open the properties. You will notice that it says it’s a string. String means that it is formatted
as Text (not a number). It needs to be formatted as text so GeoIDs that start or end with a 0 don’t
get adjusted to drop the 0 (for example, zip codes like 02144 don’t get automatically changed to
2144).

4. Since our joins need to have fields that match EXACTLY, both the excel data field and the attribute
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table field that will be matched (joined) need to both be strings/text.
5. Back in excel, notice the GEOID2 field. This is the field that exactly matches what is in the attribute
table. However, we can’t really tell right now because it’s formatted as a number and therefore
changing the numbers to read as 2.5E^10. Therefore, this field must be changd to text for the join to
work properly. Follow the image below…
a. Click on the column (B) above GEOID2 to highlight the entire column.
b. Click on the Excel Tab for Data, then click on Text to Columns:

c. Click Next to leave the first setting at Delimited.
d. Click Next to leave the second setting at Tab.
e. On Step 3, change the column data format to TEXT, and then hit Finish. This will format
ONLY THIS ONE COLUMN as text (because we still want all the data itself to be a
“number”).

6. Notice now how all the numbers in GeoID2 now actually look identical to how the GEOID field is
formatted in ArcMap. We’re getting closer.
7. You can also delete the entire column for Geo-display – label. It is not needed. Right click on
column C and press delete.
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8. Census.gov now includes the description in the cell under the column heading within the excel sheet
(e.g. Under HD01_VD01 it says Estimate; Total). However, ArcMap HATES this extra row of text –
there can’t be 2 header columns, so this entire row of text explanations must go.
Why not just keep the words and delete the headings you might ask? That’s because there are so
many picky formatting rules to follow (but really!), including a limit in the number of characters. The
data speak, believe it or not, is easier to work with.
Optional Tip – Although you need to delete the 2nd row of text, you can change the column headings
to the descriptions if it makes it easier (e.g. Change HD01_VD01 to Total). However, there can be no
spaces or periods and the heading needs to be under 8 characters. For excel sheets containing several
fields, it’s probably easier to refer to the metadata excel doc later rather than changing all the column
headings.
9. To delete the second row with all the useful descriptions (sigh), highlight the 2 nd row and right click
on the 2 and press delete.

10. To make things easier later, rename the worksheet to something comprehensible, e.g.,

Health Insurance - the worksheet name will be the identifier in ArcMap Catalog.
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11. Very important step – save your modified CSV file as a 1997-2003 Excel Workbook (.xls) – give it a
comprehensible name, e.g., 2010 Census H14_RacebyHousingTenure.xls. Save it in your H Drive …→
Aff_Data Folder
12. Extra step for Alaska, Alabama, Arkansas, Arizona, California, Colorado, and Connecticut. (Ignore

this section if you are not working in these states)
Some states have FIPS codes that start with a zero, and because Excel removes that leading zero, the table
won't join properly unless we put it back on. If you're working in Alaska, Alabama, Arkansas, Arizona,
California, Colorado, or Connecticut, you'll have to add that zero back on manually. To add the zero back on,
at the beginning of the table, under Column A, at Row2 type in: =concatenate(“0”,B2).

Hit Enter. If the result of that formula looks right (i.e. it has a leading zero), copy that cell’s formula to the
rest of the column.
You're almost done! To keep this compatible with the rest of the directions, copy all of the cells in this new
column, and right click on the GEOid2 column. Click the options below “Paste Special”, choose Values, and
your leading zeroes should be all set. Ensure your column is still named GeoID2.
Delete the column you added but be sure you still have the fixed GeoID2 column. Save the file!

Final STEP: Save your file and EXIT out of this Excel workbook with the Data – you
CANNOT have the active Excel sheet open when you work with this data in ArcGIS!
Now you’re ready for mapping!

Joining the AFF Excel Table to your Census Tract Polygons in ArcMap
1. In ArcMap, open the Census Tracts polygon attribute table and take a look at it.
2. The GeoID field is what we will be using for joining our AFF Health Insurance data. Remember from class,
the GeoID is a concatenation of the State FIPS Code (25 for Mass) plus the County FIPS Code plus the Tract
FIPS code. With this method, every single tract in the US has a unique id! This makes it much easier to
identify counties, since there can be the same county name in many different states.
3. Right-click on GEOID field name and choose Properties. Again, you’ll see it is a string type attribute field –
that’s important to know – which is why I’m making you look at it twice! That is why we went through the
process of text to columns to make the matching field in excel also text. Close the table.
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4. In Catalog, add your census excel sheet to the map. If you don’t see it in Catalog, refresh the folder
(Right-click on folder → Refresh). You will need to drill down to the sheet level, as shown below. If
there is still a plus sign, you haven’t gone deep enough! Drag in the “Health Insurance$” Sheet like
you would a shapefile.
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5. If you get the following error, it means that your version of ArcGIS and Excel are having connectivity issues.
A solution may be to save your Health Insurance excel sheet as an Excel 97-2003 Workbook (*.xls) or CSV.

6. Open the Excel Table in the Table of Contents (notice how the image looks like a little table) by rightclicking on it and choosing Open.

7. GEOID2 will be used to join this Health Insurance data to the 2018 Census Geography. These two fields
match exactly. It’s OK they have different names. Check its properties to ensure that it is also a STRING
type, close table when done.
Take a second to realize you will not being joining the GeoID to GeoID but instead GeoID2 (from excel) to
the GeoID in the Shapefile.
8. Right click on the GeoID2 field → Properties, and double check that the type is indeed a String. If it says
double, you did not convert it to text in excel and must go back and redo that step. That’s why I had you
check twice. If it says string, you are good to proceed! Close the attribute table.
9. Right click on your Census Tracts and choose Join and Relates, then select Join…
10. Fill in the dialog box as follows – you are joining attributes from an table (the excel sheet), using GEOID in
your Census Tracts layer and GEOid2 in your Excel table – click OK when done:
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12. Open Census Tracts attribute table to ensure that the join was made correctly. If so, you should see your
excel census data when you scroll to the right in the table. If they are all <nulls>, something went wrong –
most likely you did not clean the excel data fully.
If all the data is there, then things went exactly as planned and its time to thank the GIS gods and do a happy
dance. Joins can get tricky because of all the formatting requirements. Close the table.
13. It is important to know that when you make a join it is not permanent until you Data → Export Data.
Up until that point it is temporary, and some data analyses will not keep the join in the attribute table.
Exporting the data saves the join permanently as the attribute table and you don’t have to go through this
process every time you want to use it!
14. it Export the data by right clicking on the census tracts, select Data → Export Data.
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15. Save the layer with an appropriate name in the Geography Folder in your H drive (include Census tracts in the
name so you know the boundaries). It can be good to acknowledge exactly what has been joined, especially if
you will end up having multiple joined layers. Also make sure to save as a shapefile, otherwise you will
encounter an error.

16. Exporting data is always good practice to ensure something is permanent. It also sometimes resolves minor
ArcGIS glitches, such as layers not drawing on the map…or weird things happening with the labels (sound
familiar)!!
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17. Click Yes when asked if you want to add the exported data to the map as a layer.
One tip – if your area of interest is near water or has water features in it (like Boston), your tract data set may
look like this – it includes a lot of water! Why does it include water? Because people can live on boats or islands!

Using Symbology to map a Demographic Variable
Now that our join is successful, we want to use symbology to show one of our demographic variables by census
tract. Let’s open up the Metadata Excel sheet called ACS_17_5YR_B27001_medadata.csv to remember what
the field headings mean and what our options are for the demographic variables on health insurance.
Let’s map the Percent of Males 18 to 24 with No health insurance coverage.
1. In the Excel Metadata file, figure out which heading represents Males 18 – 24 with No Health Insurance.
Write down the heading name so we remember!
2. If we were to symbologize this number, it would just be a raw count of the males without health insurance in
this age range. We really want to show a Percent so we can compare census tract to census tract and so it’s
easier to understand. This is called Normalizing. It is very important when analyzing any dataset, not just in
GIS but in stats too!
3. In order to make this number a percent, we must divide the count of males 18 – 24 with No health
insurance by the total number of males 18 - 24. We DO NOT want to divide by the total population or even
by the total male population, because the percent would not make any sense.
4. Which field shows the Estimates of Males 18 – 24? Write it down!
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5. Double click on your new shapefile CensusTracts_HealthInsuranceData to get to the properties. Then click
on the Symbology Tab.
6. Since we want to map a Percent, which is a number, select Quantities on the left hand side of the symbology
box.
7. The Value: Dropdown contains all the Attribute Table Headings. Let’s select HD01_VD11– As we know, that
field holds the counts for the Males 18-24 with no health insurance. Select the first HD01_VD11 – the 2nd is
the Margin of Error number. Hit Apply – the map updates, even though the property box remains open. You
can move the Property box out of the way to see the map! See below for an example of how to change the
symbology.
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Note: As it stands, this is NOT a percent. This is just the raw count of males 18-24 with no health insurance.
It is not useful for comparisons, since census tracts are varying sizes, obviously there will be more or less of
8. In order to compare values between census tracts, we must turn this number into a percent. This means
taking the total number of males 18-24 with no health insurance and dividing it by the TOTAL POPULATION
of MALES 18 - 24. This process is called Normalizing and it is an important statistical operation that allows
comparison of two different areas. Just incase you missed it on the last page.
9.

The way we do this in arcmap, is we set the Normalization Value in symbology. We know that HD01_VD09is
the Estimate; Male: - 18 to 24 years. Therefore, in symbology change the normalization to HD01_VD09 (the
first one), as shown in the following image:
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10. Now, hit Apply. Notice how the map changes. Also, the numbers change in symbology. Now they are
fractions. That is because to make them a percent, we must multiply by 100.

11. ArcMap makes it easy to format numbers nicely, so they represent percents and only show a certain amount
of decimals or significant figures. To do so, click on Label → Format Labels…

12. There are already a bunch of different number categories. Since we are making a percent, click on
Percentage on the left. Now, two options appear. Select the 2nd option. Now, ArcMap will automatically
multiply our numbers by 100 without us having to do anything!
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13. If you hit ok now, our numbers would look like percents, but they would still have a lot of decimal places that
don’t make it easy to read (See example of labels). Still in the Number Format box, click Numeric Option

14. This opens up another box, which allows us to choose the number of decimal places or significant digits. Let’s
limit our numbers to 1 decimal place.
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15. Now press Ok, then Ok, then apply. Now our numbers are MUCH more simplified and easier to read.
16. Pick a gradual color scheme (light to dark) that you like in the Color Ramp. Press apply to see how the
different colors look. Find one you like. Something you might notice is that the grey outlines around these
colors make it really hard to see the data in Boston where the census tracts are so small. All we see is grey
where the boundaries are.
17. To clean up the color scheme, let’s remove the boundaries. You can do it one by one by clicking on each color
square and setting the boundary width to 0. OR, you could click on the first color square, hold down shift,
and then click on the last color square. This highlights all the colors at once.

18. Then, click on Symbol and select Properties for Selected Symbols.

19. Remove the outline width. This does it for all 5 color classes at once. Press ok. And then Apply.
It looks much better without the boundaries.
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20. However, now we have no idea about context or locations. Let’s add a towns layer to fix that problem!
21. In Catalog, navigate to the M drive → State → MA → MassGIS →Political_Boundaries
22. Pull in TOWNS_POLY. Click on the colored square to quickly change its symbology. Make the Fill Color: No
Color and change the outline width to 1. Pull it on top of the census tracts layer.
23. If you can’t figure out why you might not be able to drag and drop layers, it’s because you’re probably in List by
Source and not List by Drawing Order.

24. Now there is a lot more context to our map!
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25. Lastly, let’s change the name of this layer and heading in the table of contents, so that when we add our
legend it looks good! Change the name of this layer to Census Tracts. Then change the heading name from
HD01_VD11 / HD01_VD09 to % Males with No Health Insurance (18 – 24)

Excellent, almost there! I promise.

Setting a Projected Coordinate System for your Map
It is good cartographic practice to put your map into a projected coordinate system. The TIGER data is in a geographic
coordinate system and can appear stretched east – west in an odd way on your map. Mass is not actually this
awkwardly wide. You can fix this problem by setting a projected coordinate system appropriate for your region.
You will need to know the best coordinate system to use for your area. In the case of Massachusetts, we will use the
Massachusetts State Plane (NAD83) – meters coordinate system.
1. Click on View → Data Frame Properties.
2. Click on the Coordinate System tab.
3. Scroll down till you find the Projected Coordinate Systems folder. Make sure you are not still in the
“Geographic Coordinate System” folder!!
4. Scroll down to the State Plane folder– open that folder and select NAD 1983 (Meters) from the list:
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5. Find NAD_1983_StatePlane_Massachuestts Mainland (not Isl which means Islands) and highlight it:

6. Click OK. Click Yes when warned that the coordinate system is different from the data in your maps.
See how the map changes and Mass is no longer stretched. SO much better!
Congrats! You have successfully found AFF data and Census Geography data, downloaded and edited them to be
used in ArcGIS, joined them together, and mapped the data for future analyses. This routine of data search and
prep might sometimes take longer than creating the map, but doing it correctly is important to assure that
conclusions drawn from the map(s) are sound.
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Adding Base Map Data
Our map is coming along nicely, but for the final product, we should add some other data so it does not appear that
Massachusetts is floating in the middle of nowhere!
1. In Catalog, open the M drive.
2. Navigate to Country → USA →ESRIDataMap10 →usa →census
3. Pull is dtl_st. This means detailed state, and is a layer of the states with a detailed coastline. Ignore the warning
about coordinate systems.
4. Also in this folder, pull in states.sdc. This is the not so detailed states version that is ONLY meant to be used
when viewing the entire USA. Delete this layer – it looks terrible at the Massachusetts scale.
5. Change the name of dtl_st to States and drag it underneath your census tracts and change the color to make it a
neutral background color – either a very light yellow or light gray. That way, it does not draw a lot of attention.

6. Now, the only thing missing it to turn the water blue! We could find a water layer and pull it in, or we could
cheat hehehe. Double click on the Data Frame (aka Layers) or go to View → Data Frame Properties.
7. Click on the Frame tab and change the Background color to a blue. If you have a blue color scheme in your map,
make sure the blue for the water isn’t a blue used in the symbology already. Feel free to play around with the
color ramp and background. Press OK. Disregard the error about coordinate systems (at least for this week).
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8. Voila! Now our water is blue.

Creating a Map Layout
1. Switch to Layout View so we’re setting up our piece of paper.
2. You’ll likely want to switch your paper to landscape, which is done in the File → page and print setup.
3. Set up the Data Frame on the piece of paper how you would like it arranged. Then, zoom into Mass so it fills out
the whole data frame area really well.
4. Time to add some labels. Go to Customize → Toolbars and select the Draw toolbar. This toolbar is VERY handy!

5. Next to the A, click the little down arrow and select Label. This allows you to label individual features and pulls
the info from the attribute table. We will label the surrounding states! If label is greyed out, double click on the
data frame using the pointer arrow to get the slashes and activate it.

26

6. In the Label Tool Options window that appears, click Place label at position clicked. Now click inside
Connecticut. You will see it adds a label wherever you clicked. You can move these labels easily by clicking on
them and moving them.
7. Add a label for Rhode Island, Vermont and New Hampshire (don’t mind the change in color in the screenshot
here, I’m still playing around with the colors).

8. One thing you might notice is that they are so tiny. Click the select arrow on the toolbar. Then hold down the
Ctrl button and click each label. This will select them all at once.
9. On the draw toolbar, you can now use the font drop down and size drop down to make them bigger and bold.
One thing that looks really nice is to give the state labels a bit of character spacing. When they are all
highlighted, choose your font and size. Then, right click on one of the labels→ properties. Change the Character
Spacing to 20.
10. Let’s also change the color of the font to a grey, so the black isn’t so aggressive and the first thing you notice.
These labels should fall into the background.
11. Double click on Rhode Island and make it so that it is on 2 lines to better fit in the state.
12. Lastly, let’s label some of the major cities – Boston, Worcester and Springfield.
13. Using the drop down label features, find the town for Boston, Springfield and Worcester. If you don’t know
where they are, you can use the find tool
or select them in the attribute table quickly to see where
they are (if you do this, make sure to clear your selection after).
14. But a label on Springfield, Boston and Worcester. Make sure it’s an appropriate size (smaller than the state
labels). Select the 3 labels at once and add a halo by right clicking on one of the labels → Properties → Change
Symbol → Edit Symbol → Mask! Make the halo 1 pt. I know it takes forever to get there…
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15. Now, move forward with putting in the rest of the map elements outlined in the deliverables below.

Assignment Deliverables
Create 2 final maps using the census data that was joined in this assignment. One can be the data we just mapped, but
you must also make a 2nd map with a variable we did not already do together.
If you map the same variable, but Men vs Women – make sure the break values in symbology for both maps are the
same so you can compare them side by side.
•
•
•
•
•

•
•
•
•
•
•

Both maps must be normalized to show a percent
Both maps must have proper number formatting
o Percent signs
o Only 2 significant figures or 1 decimal place
Appropriate color schemes and font choices/sizes – play around with the fonts.
Title – Variable mapped, location and date (what date was the census data that we selected?)
Legend
o Make sure to include the Administrative Boundary being Mapped (aka Census Tracts)
o The variable being mapped
o Properly formatted numbers
o No Data Speak
o All necessary layers (this includes towns and states)
North Arrow
Scale Bar – sized appropriately and ending on a solid number.
Labels – Both State & the 3 cities
Cartographer Information
Data Sources (where did you download this data from?)
Explanatory text that states the variable that is mapped in case it’s too long for the legend. (see example)

Check out my map below as an example (this was created using 2015 census data, make sure your titles reflect the
2017 data)! Again, you do NOT have to follow my page set up! Just trying to show different ways of creating these
map layouts!
Also, you do NOT have to have an Inset Map – I just put it in there as an example since you’ll start needing to add
them soon.
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