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Introduction
In this tutorial, you will learn the basics of using ArcGIS Pro to explore international data including India and
Kolkata. You will symbolize data, perform spatial queries, and create a final map. This tutorial may take 4+ hours
to complete.
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Starting an ArcGIS Pro Project File
Important: When starting a new ArcGIS Project, it is very important to determine where you will be saving all
GIS data and project files before you start, since Pro makes you choose a home folder when opening the
software. You have many options for where you can save including in Tufts Box, your H Drive (for Tufts
students), your Desktop or Documents folders (if it’s a personal computer) or an external drive.
This tutorial will go through the process of saving and storing data in a GIS folder in Tufts Box, but you can
choose a location that works best for your situation. If you plan to use Tufts Box, you MUST be logged into Box
Drive before starting the tutorial. Whichever you choose, you should stay consistent and save everything in the
same place.
1. To start ArcGIS Pro, search for ArcGIS Pro in the windows search bar. Open ArcGIS Pro.
2. Click the Sign In link in the top right to sign in with Tufts Organization’s license.

3. Click Sign in with your ArcGIS Organization’s URL. Type in TuftsGIS. If this is your personal computer,
click “Remember this URL”.
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4. Click Sign in to Tufts University with Tufts University. Enter your Tufts Username and Password and go
through Duo Authentication.

5. When your back to the ArcGIS startup page, click on the option to start with a new blank Map.

6. A new dialogue box should open with the option to name your project file and where to save it. Name
your project “ArcGIS_Basics_India”. Under Location, click on the
folder icon and navigate to
where you want to save your project (remember, this tutorial will use Tufts Box, but you do not have to
if you want to save elsewhere such as the H drive or a USB).
If you want to save in Tufts Box, click on Windows (c) → Users → Your Tufts User Name → Box →
GIS_Tutorials (this is a folder I’ve already created for my GIS activities. Notice there are NO SPACES in
any of my folders! That is a good habit to get into now with GIS!) Then press OK.
Make sure Create a new folder for this project is checked so that it creates a sub-folder for this activity.
Press OK.
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7. A new blank map will open. On the left, you will see your Contents Pan. That shows all layers currently
in the map (nothing other than the 2 basemaps). On the right, you will see the Catalog pane. This is
where you can access everything associated with this project, including GIS data, saved maps, toolboxes,
etc. Double click on Folders and you will see your connection to the ArcGIS_Basics_India Folder in Tufts
Box.

Downloading the GIS Data
1. Now, we need to download the data that you will use for this exercise. The data is saved here:
https://tufts.box.com/v/ArcGISBasics-India
2. Download this ArcGIS_Basics_IndiaTutorial zipped file. Depending on the browser you are using, it
might ask if you want to save, put it in the downloads bar at the bottom or save it directly into your
Downloads folder.

3. In the Windows File Manager, navigate to your Downloads folder. Copy this zip folder over to your Box
→ GIS_Tutorials→ArcGIS_Basics_India folder and paste it there. There will be several other files in the
windows folder including the aprx (ArcGIS pro project file) and several other folders that were created
when you started this ArcGIS project.
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4. Right click on the ArcGIS_Basics_IndiaTutorial.zip file → 7 Zip → Extract Here. (Alternatively, you might
not have 7-zip installed so just look for Extract here or Extract All or something similar). This unzips all
the components that are contained within this GIS folder so you can use them in ArcGIS Pro. You should
now be able to see an unzipped file called “ArcGIS_Basics_IndiaTutorial”. The zipped file will also still be
there, which is useful to keep as a backup in case the data somehow becomes corrupted.
5. Now that you’ve unzipped the data, let’s work with it in ArcGIS Pro. Go back to your ArcGIS Pro project
file and on the right side in Catalog, right click on the folder “ArcGIS_Basics_India” and press Refresh.
This will allow us to see any new files or folders added to this folder.
Note: Whenever you add new files to a folder and the project is ALREADY open in ArcGIS Pro, you must
refresh the folder in order to see what has been added.

6. Double click on the ArcGIS_Basics_India folder and then double click on the ArcGIS_Basics_IndiaTutoial
folder. You should now see 3 more folders named IndiaBaseMap, Kolkata, World. Expand each of those
folders by double clicking on them to see the shapefiles inside. We will use these throughout the activity.
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Note: You should also see a geodatabase (the silver cylinder) that says ArcGIS_Basicis_India.gdb, along with
a ArcGIS_Basicis_India.tbx (toolbox) and a backup and ImportLog folder. These are automatically created
when you start a new ArcGIS Pro project. Any tools that we run will automatically save the new files into the
geodatabase.
7. In the World folder, click once on each shapefile file to highlight it and drag the shapefiles into the main
ArcGIS Pro window. Take note of what each shapefile looks like when you add it to the map. Are they
points, lines or polygons? Look at the icons in Catalog, that will also give you a hint.
8. To the left of the screen in the Contents pane, underneath “Drawing Order”, order the layers by
dragging them into place. You want the largest polygon layer, the countries layer, on the bottom and
the points on top so we can see them. They should be in the order seen on the screen shot. Also, notice
your colors are probably different than mine. That is because there is no default color when you first
bring layers in…its totally random until you set it.
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9. Turn all the layers off by unchecking the box next to the layer name. Then, one at a time, turn each layer
on again so you can see what it looks like. Turn on all layers except lakes and drainage in the Contents
pane.

10. Now you should have just the rivers, cities, and countries (country) drawn on the map.

Getting Around the Map
1. Click on the Map tab at the top of ArcGIS Pro.

2. The Explore button allows you to move (or pan) the map by left clicking on your mouse. You can also
zoom in and out using the mouse scroll wheel and you can click on any of the data in the map to pull up
their attributes and learn more about that particular point or polygon.

7

Tufts Data Lab
3. Select the Explore tool and try clicking on countries, rivers, or lakes. This highlights the polygon, line, or
point depending on the data and brings up information from the “attribute table” for each feature you
click on.
4. Zoom into a part of Africa using the mouse scroll wheel and hovering your cursor over the continent.
You can also hold down shift and with your mouse, draw a box around Africa to zoom directly to that
extent.
5. Additionally, you can Zoom In and Zoom Out using the fixed fixed zoom in and fixed zoom out tools.
You can return to the previous extent you were at on the map using these arrows:

6. Use the Zoom to Full Extent tool to go back to the full view of your largest dataset (in this case it zooms
to the world, since we have a layer with all countries in our contents pane).

Note: In ArcGIS, you can place the cursor over each tool in the menu without clicking to see a
description of what it does. Hover over the Explore icon and try out some of the shortcuts.
7. Can you find Gulu, Uganda?

Hint: Choose the Locate (

) tool.

You can type in Gulu Uganda in the search bar—there will be several options that come up. Right-click
on the first option and select Zoom To so that you’re brought to Gulu.
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Technically all these Gulu’s are correct…they are just different points within the city limits. Turn off the
Countries layer to see the view of Gulu in the Basemap. At the world view, Gulu is best represented as a
point. But when we zoom into the city, it is better represented as a polygon (see the dotted outline in
the basemap.)

8. You can see our point for Gulu from the cities layer is located near these points. Click on the point to
check that it is indeed Gulu and see what information is pulled up.
9. When you are done looking around, click on the full extent icon in the Navigation menu.
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10. ArcGIS Pro makes it really easy to quickly change the basemap. Try out different basemaps to see what
you like most.

11. Take a minute to look through the other Tabs up top. The Map tab has a lot of basic tools for getting
around the map and working with the data. The Insert tab has options for adding new maps, new
layouts and notes to the map. We will work with this tab later. The Analysis tab has many different tools
and toolboxes. We won’t really get into this in this tutorial. The View tab let’s us view many of the
different panes (if we accidentally close Catalog or Contents, etc). The Edit tab lets us direct edit the
data (we won’t do this either). Imagery lets us work with lots of raster data and imagery data. Finally,
the Share tab is how we save and share out our maps or upload them online.

12. Now choose Project → Save. You have already created a project file name for this
(ArcGIS_Basics_India.aprx). A project file is a very small file that contains pointers to your data sets (it
does not actually save the datasets, but we did already save those in this folder as well). The aprx
project file remembers what you had displayed in your map session and how you had it styled, along
with how far you were zoomed in/out. If you quit ArcGIS Pro at this point, you can reopen this map
.aprx file by double clicking on it in wherever you have saved in (in my case Box) and everything will be
as you left it. Thus, project files are easy ways to save work and get right back to where you left off.
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But beware –since project files do not actually contain data layers, and only have pointers to where
the data is saved, if you copied your ArcGIS_Basics_India.aprx file and tried to open it on a home
computer without also copying/moving the shapefiles, the ArcGIS Pro session would start and list the
data in the table of contents, but nothing would appear because it would not be able to find the where
the data is stored. A little red exclamation point would appear in the table of contents, informing you
that it has lost the connection to the data. If you are switching between computers, Box is a great tool to
use to help prevent this from happening.
13. Save your project file frequently and always save at the end of a session. ArcGIS Pro likes to crash! For
reals!!

Defining the Symbology Properties for a Layer
In this section of the tutorial, you will learn how to symbologize your data to assign colors to each layer so that it
starts to make sense and be intuitive to the reader.
1. Turn on the 5 layers. Let’s start with the Countries. We want these to not stand out too much, since it is
generally just providing background info right now. Click on the colored square under the layer Country.
This will pull up a new pane on the right, where we can choose a color.

2. In the symbology box, under Gallery (pre-stylized options), scroll down until you find Extent
Transparent Grey. This is already set to be slightly transparent so we can see a bit of the basemap
behind it as well. Click on this option. Feel free to try out a few others too but come back to this one
when you’re done. If you are having trouble finding the color, you can search it by name in the search
box.
Note: If you want to edit the style further, click on the properties tab next to Gallery to further adjust
the color, outline width/color, or transparency.
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3. Now let’s set the colors for the Rivers and Lakes. Click on the colored square under the Lakes layer.
4. In the symbology gallery, find Water (Area) and click it. This will update the lakes. Notice how this style
has no outline. That looks best on natural features like water and open space, so it falls into the
background and doesn’t stick out.
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5. Let’s do the same thing for rivers, which should obviously be blue. Click on the line under Rivers and
choose the Water (Line) option. If you want the blues to be darker, you can then click on the Properties
and pick a different blue.

6. Lastly, let’s set the colors and style for the cities. Click on the point under Cities and in the symbology
window under gallery, choose one of the point styles. I am going to go with the black circles.

7. Once you select the points, you might notice they are FAR too large for the map extent. Click on
Properties and adjust the size to be 3 pt. Press Apply. You can also choose a different color and symbol
shape if you wish, just make sure they are appropriate sizes for the map.
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8. There…now our map is coming along.

Adding India Data
1. Go back to the Catalog. If the Symbology pane is still open, you can either close it by clicking the X in the
top right corner or switch back to Catalog by clicking the tab at the bottom of the pane.

2.

Under Folders, expand the IndiaBaseMap folder and drag all the shapefiles in that folder into the
ArcGIS Pro window. You can hold down the ctrl key on your keyboard and click on each shapefile to drag
them all in at once.
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3. Again, the map will be messy. We’ll organize it soon. Zoom into India by right clicking on the new layer
State → Zoom to Layer. This will zoom to the extent of this layer (India states) so it fills up the screen
and we can see a lot more detail.

4. You can group the India data layers all together. If they are no longer all highlighted, hold the CTRL key
and click on each one in turn to highlight them. When they are all highlighted, right-click on one of them
and choose Group as shown below:
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5. Rename the “New Group Layer” to India by clicking slowly twice on the label and entering in India.

6. Perform the same grouping on the World data so that it is in its own group as shown below. If you click
on the first and last datasets, while holding shift, all layers will get highlighted and you can group them
faster.
Grouping data is a great way to keep your contents organized when you start to have lots of layers.
7. Turn off the World data group. Notice how even though the layers inside the World group are checked,
if you turn off the whole group – all the layers turn off. You can minimize it too if that’s helpful.

REMINDER: Save your map project frequently and always save it at the end of a session! Saving can
also be accomplished by pressing the 3rd icon on the top toolbar.
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Setting a Coordinate System for the Data Frame
The rest of this tutorial focuses on India, so we are going to set a coordinate system that better maps India. This
will also ensure that any spatial queries you do will perform correctly. We will talk a lot more about projections
in a few weeks, but setting the right projection is a very important part of GIS.
1. Right-click on Map in Drawing Order and choose Properties.

2. Click on the Coordinate System tab.
3. In the coordinate system dialog box, you will see information in the bottom panel for the current
coordinate system (GCS_WGS_1984). We want to change this.
4. Scroll down and click on Projected Coordinate Systems, then UTM then on WGS 1984, then Northern
Hemisphere, and finally on WGS 1984 UTM Zone 44N as shown below and then OK:
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5. Turn on the world data and zoom to the full extent ( ). You will see that this severely distorts the rest
of the world. But it makes India look perfect! Having the right coordinate system is a crucial part of GIS.
6. Zoom back to India when you’re ready and again turn off the world data.
7. To clean up the map, uncheck all the layers except for the railway, district, and state layers within the
India Group.

Defining the General and Symbology Properties for a Layer
In this section of the tutorial, you will learn how to organize your data layers' properties to start bringing some
coherence to the map. You will also learn how to symbologize the data layers to start making a more interesting
and readable map.
Assigning Proper Layer Names
First, you need to give the layers better names than what they have (e.g., SUB_DISTRICT → "Sub-district"). When
we see data with underscores and shorthand or all caps, this is commonly referred to as “data speak”.
1. Right click on the SUB_DISTRICT layer and choose Properties (alternatively, you can click twice slowly on
the data layer name or press the F2 button).
2. When you see the Properties dialog box, click on the General tab and for layer name, type in Subdistrict instead of SUB_DISTRICT. Press OK when finished. Having proper names is very important
because the legend will eventually be connected to these layer names and we need the viewer to easily
be able to understand!
Note: Changing the name in Contents does not change the name of the original data set in Catalog - it
only changes the name as it appears in this Project Session (.aprx) of ArcGIS Pro and as it will appear on
your final map.
3. Rename all the layers so they are not in all caps and do not have data speak. Points will be deducted on
assignments for having non-standard “data speak” names like "cntry08" appearing in your map.
Assigning Proper Colors
Your map would be a lot better if the layers were in a logical order and colored properly.
1. Look at each layer one by one. States are the largest administrative boundary, then Districts, then SubDistricts. We want to be able to view them in a logical order. However, we also want to perhaps see the
State boundary outlines on top of the districts to help make sense.
2. Turn on only the State and the District layers.
3. Click on the State layer. Notice how when we select a specific layer, more tabs up top appear. This is
because ArcGIS Pro is contextual. When you click on a layer, more options appear that allow you to work
on that layer (much like excel or word).
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4. Click on the Appearance tab and then click Symbology. This is another way to get to the
color/symbology options. We are going to make the States layer see through, with just outlines so we
can see the Districts underneath.
5. In the symbology box to the right, click on the square color to set the color properties (commonly called
symbology).

6. Click on the Properties tab. Under Color, select No Color and make the outline width 2.00. Make the
outline black or dark gray. Press Apply when you are finished setting the color properties.

Note: Remember, you can also access these color properties by clicking on the symbol underneath the
layer name in Drawing Order.

7. Drag the State layer to the top of the India group in Contents. Now that it is hollow (aka see-through)
you can see the District layer underneath and better understand which districts are within each state.
8. Change the color of the District layer to a beige and give it a 1.0 gray outline width as shown. If you click
Color and then Color Properties custom colors can be created.
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9. Using what we’ve learned about symbology, give appropriate colors to your other layers. Check out
what’s in the gallery too, as there might be pre-styled options for railroads. Turn the layers on and off in
order to view the ones you are currently symbolizing.
10. When finished, choose File → Save again. Now your project file will remember all the colors and names
you assigned. It’s starting to look better…

Symbolizing a Layer Based on an Attribute Value
Some of your layers would look better if you could distinguish between different types of features or variables
(attributes) within the same layer. The State layer, for example, shows India’s state boundaries but doesn’t give
us more information when drawn with a single color. You can use an attribute field to symbolize your data to
reflect the field values.
1. Since we’ve already stylized the States layer, let’s bring in a 2 nd States layer. Go back to Catalog and drag
in the State shapefile again. Notice how you can bring in the same shapefile multiple times to style
differently.
2. Right-click on the new State layer and choose Open Attribute Table. Look at all the different columns
(attributes) and the headings. Some we can sort of guess what they mean, others we have no clue
without further information.

3. In order to learn what the column headings represent; we need to look at the Metadata. Metadata is
documentation explaining what is in your attribute table (and other info about the shapefile) and gives a
definition for each of the field headings. To know what attribute fields are appropriate for use in
symbolizing your data, you must be familiar with the attribute table structure, its fields, and the possible
values of each significant field.
4. Go to the WINDOWS file folder (the regular folder that you get to through “computer”) and navigate
to where you saved the tutorial data (for me, that was Box → GIS tutorials →ArcGIS_Basics_India →
ArcGIS_basics_IndiaTutorial.
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5. Open the IndiaBaseMap folder and then there is a subfolder called DESCRIPTION. Open up this folder
using your Windows File Manager (not Catalog). Take a look at the STATE.PDF to see what the
abbreviations in the attribute table columns mean.

6. Let’s say we wanted to map and visualize the population of cultivators by state. The field TOT_CULT
holds the values for the total cultivators. We can also see there is a field called Tot_W which represents
the total number of workers.
7. In the Content pane, click on the State layer and then click the Appearance tab. Click the drop down
under Symbology and select Graduated Colors.
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8. The Symbology pane will appear on the right. Change the drop down next to the Field to be TOT_CULT.

Notice that the options in the Value dropdown are the field headings you saw in the attribute table.
9. The resulting map is interesting and shows the COUNT of cultivators per state. Now, we see the states
with larger numbers of cultivators. What states have the greatest number of cultivators? Click on the
states in the map to pull up all the information from the attribute table.
Note: If you can’t see the data, make sure this state layer is on and nothing is covering it. Feel free to
close the attribute table for now so more of the map can be seen.
10. Check out the different color scheme options to find one that you like. A color scheme that is light to
dark and doesn’t have TOO many colors is best for showing low to high numbers.
11. Take a minute to look at the map and what it’s telling us. However, maybe we want to map the states to
show the percentage of cultivators out of the total number of workers, rather than just the total count
of cultivators. To do this, we need to normalize (aka divide by) the data by the Total Workers field to
make it a percent.
12. In the Symbology pane, find the box for Normalization. This is the field that we want to “divide by” in
order to turn it into a percent. Choose the field, TOT_W – when you use this Normalize function, it
simply divides the top value by the normalization value to give you a fraction, so in this case Total
Cultivators/Total Workers.
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13. The resulting map shows the number of cultivators in each state as a fraction of the total workers (e.g.,
0.541022 means 54% of workers are cultivators). The numbers are also not very nicely formatted at the
moment.
14. In order to format the numbers so that they are actually percents, click on the Advanced Symbology
Options.

15. There are lots of ways to format the numbers a lot nicer here. In the Format Labels section, under
Category, choose Percentage. Then select the option for “Number represents a fraction. Adjust it to
show a percentage”. Lastly, change the number of decimal places to 1.

16. Click back on Primary Symbology to get back.

17. There, that makes the numbers easier to read and slightly cleaner!
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How did the message of the map change? When we were just looking at the count, Rajasthan had a high count
of cultivators, but it seemed like Arunachal Pradesh (on the east) had a low number of cultivators. But when we
turned it into a percentage, now Arunachal Pradesh had a very high percentage of its workers that were
cultivators! We didn’t see that when it was just a count because likely their total population is a lot smaller, so
therefore the count was a smaller number…
This is why normalizing is so important! It allows us to compare apples to apples!

18. Use the skills we learned to map the same variables (percent of workers who are cultivators) using the
District layer instead of the State layer. Compare the two layers. When you look at the districts layer,
keep the hollow states layer on so you can see the state borders.
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Now, you can see a lot more detail about where within the state there are a high or low percentage of
cultivators. With smaller administrative boundaries, we can see THAT MUCH MORE detail in location data.
19. Let’s make sure to remove the data speak from the layer. Change the heading name (eg.
TOT_CULT/TOT_W) to Percent of Cultivators. If you click twice SLOWLY on the text in the Contents Pane
or press the F2 button, you can type right in and change the name. Keep the layer name as District.

20. How would we go about creating a population density map for the District layer (total population
divided by area)? The Tot_Area column is area in square kilometers of the district.
Note: If you want to keep a layer symbolized one way (e.g., percent cultivators by District) and also have
another layer showing the data by district (e.g., percent illiterate), you can add the District layer again
from Catalog so you don’t mess up the symbology you just took time setting.
21. Try creating other maps based on the attribute table values by State, District, or Sub-District – the field
(column) names in the attribute table are the same for all of these.
22. Save your project file when finished.

Selecting and Mapping the Largest Cities in India
In this section, we’ll use the Town layer which includes all of India’s towns to select and map only the towns that
have a population greater than 1 million people.
1. Turn on the Town layer. Drag Town to the top of the group in the Contents pane if it is not already. If the
Contents pane looks too messy, you can collapse your symbolized data layers by clicking the arrow next
to the name.
2. Right-click on the Town layer and choose Open Attribute Table.

.
3. Scroll to the right in the table until you see the TOT_POP field. We’re going to use this field to select all
the towns in India with 1 million or greater total population.
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4. Go to the top menu, click on the Map tab and click on Select by Attributes.

5. In the query box, make sure Input Rows is Town and Selection Type is New Selection. Click on Add New
Expression to create a selection. Note: the input Rows might say “India/Town”. That’s just indicating it’s
the town layer within the India group.

6. In the query box, use the drop downs to select TOT_POP is Greater than or equal to and then type in
1000000. Accept the default Selection Type of New Selection. Leave “Invert Where Clause” unchecked.
Click OK.
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7. You should see that there are 31 towns selected (look at the bottom of the table). If you right-click on
TOT_POP and select “Sort Descending” you will see the towns with the highest population (the selected
towns) at the top of the attribute table. All the towns are selected in teal in the attribute table and in
the map.

8. Close the table. The towns will remain selected on your map.
9. To create a new layer (and permanent shapefile) with just these large cities, right-click on Town and
then Data → Export Features (as shown below):
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10. You’ll get a new dialogue box like so. This is saving the selected towns as a shapefile. The resulting layer
is set to save in the geodatabase that was created when you started this project. To double check the
location, click on the folder next to Output feature Class. Make sure it is saving to where you expected.
Name the layer Large_Cities”. Press Ok.

11. Now, a new layer has been added to the top of your Contents pane. If you look in the Catalog and
expand the geodatabase, you’ll see that a new feature class has been created. You can reuse this feature
class in any future mapping project!

12. Change the name from Large_Cities to Large Cities (remove the underscore).
13. Drag the Large Cities (and any other layer that needs to be moved) into the India group so that they are
at the top of that group. Turn off the Town layer, so you only see the Large Cities.
14. Click on the Clear Selection icon to turn off your original selected towns. This is located in the Selection
group under the Map tab on the top menu bar. Even if the Town layer is off, the selection remains until
you clear it. If nothing is selected, the “clear” button will be grayed out.

15. Now, let’s use symbology to show the large cities with different sized points based on the total
population. This is called graduated symbols. Click on the Large Cities layer and go to the appearance
tab and click on the drop down under Symbology. Select Graduated Symbols.
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16. Fill out the symbology properties so the value field is set to TOT_POP.

17. To change the color or shape of the symbols, click on the point next to Template. You can then choose a
symbol under Gallery or click on the Properties tab and adjust the color, size, shape, etc.
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18. Click on the back button to return to primary symbology.

19. You can also adjust the number of “classes” by changing the box that says Classes. You can also adjust
the break values of the classes by selecting a different Method.

20. We’ll also want to format the labels nicely. Click on Advanced Symbology Properties. Under Format
Labels, set the Decimal Places to 0 and check show thousands separators.

21. Click back on the first icon to get back to primary symbology.
22. Save your map file!
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Selecting Towns based on their location to Railroads
Let’s say we wanted to see which towns in India have sufficient access to railroads and which towns do not, and
we want to estimate the population in each group. You can use the Select by Location function to select features
based on their spatial relationship to other layers.
1. Turn on the original Town layer (NOT the large_cities layer we just created) and the Railway layer. Pull
Railway to the top of the India Group in the Table of Contents.
2. On the Map Tab, click on Select by Location.

3. In this tool, we want to select towns that are within 5 miles of a railroad. Set the Input Features to
Town. Set the relationship to Within a distance. Specify a search distance of 5 Miles. And the Selecting
Features should be set to Railway. Make sure it is set to New Selection. Press OK.

You’ll see that many towns are within 5 miles of a railroad. How many people live within these selected
towns? Let’s find out.
4. Right-click on the Towns layer and choose Open Attribute Table.
5. You will see 3,258 out of 5,161 towns are selected. Scroll to the Tot_Pop field and right click on its field
name and choose Statistics as shown below:
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6. This will open a histogram of the TOT_POP distribution. It includes both the selected features and all
features. To view only the selected records (the towns within 5 miles of a railway), click on Filter:
Selection at the top
You’ll see descriptive statistics on the right for all towns and the selected towns, including a “sum” value
of ~245 million people this live within the selected towns. That’s our answer!
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7. But what if we also wanted to know how many people don’t live in a town within 5 miles of a railroad?
We could do some simple math and take the total sum for the dataset and subtract the selected sum. Or
we can do it using the GIS tools.
In the attribute table, switch to the Town tab to get back to the attribute table. Then, click on the Switch
Selection Icon at the top of the attribute table, as shown below. Now all towns that are NOT within 5
miles of a railway are selected.

8. In the attribute table, click back on the tab for the Town – Distribution of TOT_POP. Now, the histogram
and statistics have updated to show this new switched selection. Check the SUM value for the selected
features. Now the sum should be updated to be ~ 40 million people that are not within 5 miles of a
railway.
9. Clear your selection, close the statistics box and all the attribute table tabs.
10. Save!

Labeling a Layer Based on an Attribute Field
You can label features based on data in the attribute values. Let’s label the States.
1. Turn off the towns and railways. Turn on your symbologized State Layer showing % cultivators and leave
on the Large_Cities. Turn off any other layer too (the less layers you have on, the faster things go).
2. Click on the State Layer in the Contents pane. In the new tabs that pop up, click on the Labeling tab.

3. Click the button for Label and make sure the field is set to Name. This will pull the info from the
attribute table in the “Name” column – aka the State names. Labels might take a minute to show up.
You can check the loading progress by looking at the spinning icon in the bottom right corner.
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4. Note that the names for some states are repeated – that’s because the state may have islands or other
non-contiguous sections that are represented a few times in the database, and so get multiple labels. To
get rid of the double names, right-click on the State layer and click on labelling properties.

Click on Position then Conflict Resolution (
) then underneath Remove Duplicate Labels use the
drop-down to select Remove All. There, much better!

Changing the Formatting of Labels
Now, let’s improve the Labeling format so they look more like Administrative Labels.
1. Click on State again and up to the Labeling Tab. You’ll mee many options for formatting under Text
Symbol, along with some pre-styled label options.
2. Try a couple of the premade label styles to see how they look. When you’re done, select the POI (Black
Halo). This is nice because it automatically puts on a “halo” and gives a bit of character spacing (which is
important with administrative boundaries). But it’s a bit small. Adjust the font size up to 10 or 11
(depending on your screen size) and make sure you are zoom all the way into India (and your ArcGIS Pro
session takes up your full screen). The bigger the map, the more detail you can see without it being
crammed.
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Using Large Scale Data – Kolkata
We also have more detailed (large-scale) data available for Kolkata to work with.
1. Before switching over to the city scale, let’s set a bookmark for India so we can easily get back to this
view. Make sure India is zoomed in as much as possible and centered in your screen.
2. Then, on the Map Tab, click on Bookmarks → New Bookmark. Call it India.

3. Now, if you zoom in/out of move to a different place in the map, you can quickly and easily get back to
your view of India by going to the bookmarks tab and clicking on India!
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4. Open Catalog again on the right. If you closed out of it, you can get back to it by going to the View tab.
→ Catalog Pane.

5. Expand the folder for Kolkata and drag in all the shapefiles in that folder.
6. Group the data into a Kolkata group, as we did with the India and World data by highlighting all the new
Kolkata datasets, right clicking, and pressing Group.
7. Turn off the group of data for India, so now only the Kolkata data is visible. Zoom into this area by
holding down SHIFT and drawing a small square right around the datasets. Another great way to zoom in
is to right click on the Kolkata group and click Zoom to Layer.
8. Re-write each dataset so that it is not in all CAPS. Remember, a quick way to change the names is to click
on the layer and press F2 or to click twice SLOWLY on the name of the layer.
9. Put them in an appropriate order (points, lines, polygons) and with the largest layer (wards) on the
bottom so we can see the parks and water on top of it.
10. Color/Symbolize your layers appropriately. Make sure that your parks are green and your water is blue –
don’t have outlines on either color.
11. Try mapping some of the data in the attribute table for the Wards or landmarks data (categories). There
is metadata in the Kolkata folder, which you should access via Windows File Manager.
12. Try out different basemaps to see what you like at the City scale.
13. Save your project!!!

Measuring Distance and Area
1. Click on the Measure tool in the Main toolbar under Maps tab.

2. Click somewhere on the map to start a measuring line. Drag the line somewhere else and click again.
You will see two measurements reported in the Measurement window. The first, segment, gives the
distance of the line you just drew. The second, Path, gives the total distance.
3. Click on a third point in the map and make another line segment. Every new line you create, the tool
sections off segment and path for each of your different lines. Sum gives the total distance of all your
different lines.
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4. Double-click on the map to stop measuring.
Note: If you want to measure in a different unit, click on the little black triangle as shown below and select a
new distance unit:

5. Try calculating the area in acres of a park in Kolkata (Go to the Kolkata Group and in the Parks Layer,
right click and press zoom to layer to guide you. You might need to turn off LANDMARK and ROAD to
see the PARKS.)
6. Use the polygon tool in the Measure tool as shown below and set the area units to acres. You might
need to click the down arrow next to the measuring icon and select “Measure Area”. We’ll learn a better
way to do this later.

7. Click each time you want to add vertices. Double click to close the polygon and get a total area.
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Drawing a map at a set scale
Many professional map users expect printed maps to be at a standardized scale. USGS topographic maps are
printed at 1:100,000 scale (1 inch on the map equals 100,000 inches in the real world or about 1.58 miles) and at
1:24,000 scale for example (1 inch on the map equals 24,000 inches in the real world, or 2000 feet or about 0.38
miles). In ArcGIS you can scale your map to any scale, but you are also offered standard scales from which to
choose.
1. Set the scale of your map to 1:10,000. The scale is located on the bottom left of the map. This is very
“large scale” map (lots of detail, very small area displayed).

2. Now, change it to 1:24,000. This is a very typical “city” scale. So it would work well for a map of
downtown Kolkata but not for a map of a state or the entire country.
3. Experiment with some of the other map scales. What preset scale would be best to fit the entire Ward
administrative boundary layer?

Creating a Map Layout for Printing or Graphic Export
Now that all our data is mapped and symbologized, it’s time to make a map! It is important in a map not to
include too much information so that map is not legible. You would not want a map that includes all the data
layers you have in your ArcGIS Pro session from this tutorial.
In order to create a printable map, you will add a new layout to the project. A layout is a paper view of your
data, much like viewing the page layout when you are working in a word processing software. In ArcGIS Pro, you
can add multiple layouts to a project!
For this activity, you will create a map of all of India or Kolkata. See the example maps at the end.
When you create a map, it should include:
•
•
•
•
•
•

The map itself, duh
A descriptive title, including key location and dates
A legend – No data speak. All colors, symbols and numbers formatted nicely
A scale bar (with appropriate units and sized well)
A north arrow
Cartographer information (name, date, class)
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•
•
•
•

Data Sources
Any annotation you might want to include about the map (optional)
Labels (optional)
Locator Map (optional)

Setting up a Map Layout
1. Before you start a map layout, it is important to think through what you want to do and how you want
your map to look. What do you want to show? How large do you want your final map to be? Portrait or
landscape orientation? Do you need space for additional text or graphics? This tutorial example will
assume a printer paper size (8.5x11 inch) map but often you are making map for publications where
they must be smaller, or for PowerPoint where they need to be a certain size (e.g., 7.5x10 inches), or for
posters where they may be much larger than 8.5x11.
2. Click the Insert Tab → New Layout. In the dropdown menu, select Letter (8.5” X11”).

3. This will open up a new window called “Layout” on a new tab. To get back to your map, you can click the
Map tab. But for now, you’ll want to work in this Layout tab. Notice how the top toolbar now has
different options for adding map elements.
Note: if your layout opens in a split screen view with your map, you can click on the title tab that says
layout (highlighted in red below) and drag it up to the map tab. When the map tab is highlighted in blue,
release and your layout tab will be next to your map tab like in the screenshot below.

4. Now, we need to place our Map on this piece of paper. To do so, click on the Insert tab and then Map
Frame and select the image of our map. Draw a box where you want the map to be placed on the
paper. Make it ALMOST as big as the paper, leaving a little border for “printable margins”. You can
adjust the size of the Map Frame using the vertices on the corners of the map.
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5. On the left under Contents, click the down arrow to expand the Map Frame. Now you can see all the
layers in this map and turn them on and off. In this example, I am going to map the % cultivators – but
you can map what you like. Turn off any layers that are not needed to make this final map.
The Layout Toolbar
It is very important to understand the difference between being in a Layout vs a regular Map. When you are in a
Layout, there are a lot of similar tools in the Layout (zoom in and out, pan) but the Layout tools work on the
layout as if you were zooming in and out of the paper itself), while the same tools on the Map toolbar work on
the data inside the data frame (e.g., zoom into Madagascar).
1. Take a minute to look in the Layout Tab to see the tools, hovering over the tools to see what they do in
the Layout Tab.
The Map Toolbar

The Layout Toolbar

2. The navigate icon allows you to move the piece of paper. The full extent icon
page is in view. The 1:1 tool
at actual print size (100%).

zooms so the whole

is particularly useful to see what the map features and text looks like

3. See what the other tools in the Layout tab do as well. Orientation would allow you to change the page
orientation quickly and painlessly.
4. Moving and re-sizing the map or any map element works similarly to most other programs. The key is
selecting the element first. Once you do that, you can use the vertices to resize anything or move the
map element.
5. Now it’s time to position the actual data within our Map. At the moment, we are too zoomed out from
India and it’s not centered. We want to zoom in as much as possible so India takes up most of the page.
The more we zoom in, the more detail we can see!
6. In order to move the position of the data within the map, we need to Activate the data frame. In the
Layout Tab, click Activate to be able to interact with the map and zoom in/out and pan around.
Note: You can also right click to activate the map.
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Notice how the toolbar switches back to the map tools used for mapping and analysis. Now, you can use
the Explore tools to zoom into India or Kolkata. Hold down shift and draw a box around the data you’re
mapping. Then use the explore again to position India or Kolkata on the page. Make sure the data fills
out as much of the Data Frame as possible without cutting anything off. The bigger the data, the more
we can see!

7. Once India is in position, you can deactivate the map by clicking on the Layout tab and then Close
Activation. This will lock the data in place and bring us back to the layout tools. See examples below for
India Map.

8. This is about what your map should look like, with India or Kolkota taking up the entire page. Also, if you
are using a basemap that has any labels – make sure to turn off the “reference” layer so the labels are
not on. We will only use our labels.

Inserting a Title
1. To insert various map elements (like the title, legend, north arrow, scale bar, etc), click on the Insert
Tab. Look over all the icons to see what you can insert here. There are lots of options. Note: if you don’t
see this tab, make sure you have closed out of the map activation.
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2. Let’s start with the Title. In the Graphics and Text box, there are lots of ways to add text. Click the big A
to add straight text and click in the map where you want the title to go.

3. Type in a title that is descriptive of what we you are mapping, including the variable being mapped, any
relevant dates and locations.
4. To adjust the size and alignment, click on the title text and a Text Format tab will appear. You can adjust
the font, color, and size of the text here. If you need to adjust where the text breaks onto the next line,
there are further text options on the right side. You can also click on Text Symbol for more text
formatting options like alignment, character spacing, etc.

5. Make the title pretty large so it catches the readers eye first (visual hierarchy). Take time picking
appropriate fonts and stylizing it nicely. Don’t just accept defaults, I hate that and will take points off
for it later. Making maps is as much of an art as it is a science!
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6. You might want to add a background so it’s a bit easier to read the text. To do so, you would add a
rectangle and move it behind the text. On the insert tab, click the rectangle and draw a square around
your text.

7. Now, a Rectangle Format Tab pops up. Here, you can select a Fill and a Stroke (outline) color if you wish.
You can also adjust the transparency in the fill. I am going to make the background white, with no
outline, and slightly transparent. To adjust transparency, in the Fill → color properties, there is the
options to adjust transparency.
8. You might notice that now the box is ON TOP of the text covering it. Just like with layers in the map, the
map elements are layered in the order they are listed in the Contents pane. Move the Text above the
Rectangle in the contents. You can also turn the map elements on and off here too and you can lock
them in place so that they can’t accidentally be edited.

9. Now, our title is looking good. Nice and big and really pops.
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Inserting a North Arrow and Scale Bar
These are all required elements on all maps. You access them by going to the Insert tab.
1. Click on the North Arrow dropdown. Select one that you like. Put it in a bottom corner, out of the way.
You can adjust the size, but don’t make it too big. If you don’t like the style, simply click once on it and
press delete. Then reinsert a different one.
2. Click on the dropdown options and pick a Scale bar that you like. Put it in the bottom corner next to the
north arrow, out of the way. If you don’t like it, simply click once on it and press delete. Then reinsert a
different one.
3. In the upper menu, click on the Scale Bar Design tab, change the Number of divisions to 1 and Number
of subdivisions to 2. This takes away all the junky numbers inside the scale bar and makes it cleaner.
Also, since we are working in India, the units should be in KM not miles. Change the Division Units to
Kilometers. Set if you want the label position above, below, etc.
4. Make sure the scale bar doesn’t cross over onto your data. Use the edges to change the size. Also, make
sure it ends on a number that makes sense (aka 1000KM, 500KM…not 1320KM). You can also adjust the
label placement, whether you want it on the right, below, above, etc.
5. Again, notice how in the Contents window, there are now “layers” for Text, North Arrow and Scalebar.
You can now turn them on and off, like they are a layer. You can also click on the little lock, to lock the
style in place so they can’t accidentally be moved, edited, or deleted.

Inserting a Legend
Now, onto the legend, which is the trickiest part.
1. Click on the Insert tab and then Legend. Draw a box where you want the legend to be placed. Click on
the corner vertices to adjust the size and placement.
2. Click on the new Legend tab and choose a font.
3. Now we need to adjust the style of each layer in the legend one by one. In the contents pane, notice
how a legend has been added and if you expand it, you can see all the layers. These will be the layers
that are on in the legend. Uncheck everything except the layers on in your map. Turning them off in the
legend won’t actually turn them off in the map though.

44

Tufts Data Lab

4. If there is any data speak in your legend (underscores, all caps, etc), that needs to be cleaned up on the
actual layer itself (under the Map Frame section). For example, Large Cities has data speak. The Layer
Name, Large Cities, looks ok but the heading, TOT_POP, needs to be edited so it’s clean and clearly says
the attribute we are mapping. Renaming it here then renames it in the legend! Clean up any other layers
with data speak.
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5. You might want to adjust the font sizes/emphasis for the layer names, headings and labels. Right click on
Legend and click Properties. This will bring up more options on the right to all the legend contents.

6. On the right, click on the 3rd icon “Display”. Here, we can assign a background color and border style to
the legend if you would like. I am going to choose a white background, no border, and I’m going to make
the X gap and Y gap .1 inches for background to give it a little extra room around the sides.

7. Next, while Legend is highlighted, click on Text Symbol and then change the drop down to Layer Names.
Now, we can adjust the size and fonts for the layer names. I am going to choose the matching font from
my title and make them bold and size 14. Click Apply to see changes.
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8. Now, change the drop down to “headings”. This will edit the style of the text underneath the layer
name. I’m going to make this bold and size 13. That way, they are slightly smaller than the layer titles.
9. Lastly, change the drop down to “labels”. This will edit the style of the text next to the symbols. I’m
going to make this regular and size 12 with the matching font. That way, it is smaller than both the layer
titles/headings and has different emphasis.
Play around in the other legend options to see what happens.

Insert Cartographer Information, Data Sources and any other annotation
1. You will use the Insert tab again to insert your cartographer information. Click the A to insert a text box.
2. Add your name, class info and today’s date and put it somewhere that is out of the way but makes sense.
3. Again, click on the Text tab to adjust the style of your Cartographer info. Edit the font, size, alignment,
etc.
4. Add another text box for Data Sources. This data came from India’s Census.
5. You could also use this to add any annotation for the map, such as any further explanation of the legend
or perhaps an explanation of what the map is showing.
6. If you want, put a background behind the text like we did for the title.

Removing the Base Map Citations
If you are using a streaming base map, there is likely an annoying citation in the bottom right corner.
1. To remove the citation, go to Insert → Dynamic Text → Service layer credits.
2. Draw a square in the map and the text will move there…
3. Then just moveeeee it off the piece of paper lol. You can’t delete it, it will just go back to the corner. But
if we move it off the piece of paper…voila, no more annoying citation text.

Adding a Second Data Frame to Show a Locator Inset Map
You can add a second (or more) data frame to your Layout. This can be handy for putting in a small "locator"
map that shows the location of your main map in a greater context. See the following graphic:
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Multiple data frames can get a little tricky and will take some practice.
1. In Layout View, choose Insert → New Map from the top main menu. A blank new map will appear on
the top tab. Click on this new tab and rename the data frame to Inset Map by clicking on the Data
Frame in Drawing Order twice slowly.

2. If you’re making a map of India, your locator map should be of the world or at least Europe, Africa, Asia.
That way, we are seeing where India is in the global view. If you are making a map of Kolkata, your
locator map should be all of India – so we can see where Kolkata is within India. Locator maps are always
relative to the scale of the main map.
3. Since I am making a map of India, I will want the global view for the locator map. We also need to bring
in some data again. Open Catalog on the right and drag in the Country shapefile in the world folder. Also
drag in the State shapefile in the IndiaBaseMap folder.
Note: If you are mapping Kolkata, drag in the State layer and the Ward layer again.
4. Set a color for both the country and state layer. One tip for the state layer is to not have any outlines.
That will remove the state borders and make India look smooth, as we really only care to show India as a
whole…not the states.
5. Go back to your layout view of your final map. Click on the Insert tab then on Map Frame. Select your
new map and draw a smaller box in one of the corners where it fits nicely.
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6. You’ll now likely need to adjust the zoom and position. Click on this new map and then in the Layout
Tab, click Activate. Zoom in to the appropriate scale and center the map. If needed, adjust the size of
the data frame by closing the map activation and moving it.

Setting up Locator Map Boundary Box – For Kolkata Maps only
If your main map is of Kolkata, it can be a bit challenging to see that data when you are zoomed to all of India in
your locator map. Therefore, we will use something called a Bounding Box.
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1. Insert the 2nd Data Frame in your layout as directed above and make sure the zoom is set to India. Close
the map activation when done setting the zoom and placement.

2. Select your inset map using the select tool (

).

3. Go to the Insert tab and select Extent Indicator in Map Frames group. This adds a box to your inset map
showing the location of your main map within the locator map. Now the area around Kolkata is clear.

4. If you want to change the size and color of your extent indicator, in the Contents Pane, right-click on the
extent indicator layer underneath Map Frame 2 and select Properties.

5. In the new panel on the right, make sure the source is set to the original Map Frame (just known as
“Map Frame” here). Click on the boxed symbol and go to Properties to change the size and color
(perhaps choosing a color that is used within your main map for cohesion).

Voila! Almost done, I swear!

Exporting your Paper Map
When your map layout is perfect (or good enough, ha), you will need to export your map to a digital graphic
format like .pdf, .jpegs, .png or .gif.
50

Tufts Data Lab
1. When you have your layout the way you want it, on the top menu, choose Share tab → Layout Export.

2. In the Export dialog box that appears on the right, navigate to where you want to save it. In this case, I
will save it in the same box folder I have been saving everything. Give the image a descriptive name such
as India_Cultivators_Map.
3. For Save as Type, choose a format - we recommend .png, .gif, .jpeg, or .pdf because they come out well
and are readable across a variety of platforms. I am going to use a .png.
4. Before you export, adjust resolution under the Resolution (DPI) area. Digital images meant to be seen
on a computer screen do not need high resolution. Change the resolution to 300, which should be the
maximum.
5. Press Export when you are ready to go - the process will take a minute.
6. Check your results by navigating to the windows folder outside of ArcGIS and opening the graphic - if
you’re not pleased, experiment with different resolutions and compare file sizes.
7. Once you have created one map in a layout you like, save the project file. That way you can return to it
later if you need to change something.
Check out my example map at the end of this tutorial.
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