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Introduction
In this tutorial, you will learn the basics of using ArcGIS Pro to explore local Somerville data. You will symbolize data,
perform spatial queries, and create a final map. This tutorial may take 4+ hours to complete.

Starting an ArcGIS Pro Project File
Important: When starting a new ArcGIS Project, it is very important to determine where you will be saving all GIS data
and project files before you start, since Pro makes you choose a home folder when opening the software. You have
many options for where you can save including in Tufts Box, your H Drive (for Tufts students), your Desktop or
Documents folders (if it’s a personal computer and not Tufts Remote Lab or TTS VDI) or an external drive.
This tutorial will go through the process of saving and storing data in a GIS tutorial folder in Tufts Box, but you can
choose a location that works best for your situation. If you plan to use Tufts Box, you MUST be logged into Box Drive
before starting the tutorial. Whichever you choose, you should stay consistent and save everything in the same place.
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1. To start ArcGIS Pro, search for ArcGIS Pro in the windows search bar. Open ArcGIS Pro.
2. Click the Sign In link in the top right to sign in with Tufts Organization’s license.

3. Click Sign in with your ArcGIS Organization’s URL. Type in TuftsGIS. If this is your personal computer, click
“Remember this URL”.

4. Click Sign in to Tufts University with Tufts University. Enter your Tufts Username and Password and go through
Duo Authentication.

5. When your back to the ArcGIS startup page, click on the option to start with a new blank Map.
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6. A new dialogue box should open with the option to name your project file and where to save it. Name your
project “ArcGIS_Basics_Somerville”. Under Location, click on the
folder icon and navigate to where you
want to save your project (remember, this tutorial will use Tufts Box, but you do not have to if you want to save
elsewhere such as the H drive or a USB).
If you want to save in Tufts Box, click on Windows (c) → Users → Your Tufts Username → Box → GIS_Tutorials
(this is a folder I’ve already created for my GIS activities. Notice there are NO SPACES in any of my folders! That
is a good habit to get into now with GIS!) Then press OK.
Make sure Create a new folder for this project is checked so that it creates a sub-folder for this activity.
Press OK.

7. A new blank map will open. On the left, you will see your Contents Pan. That shows all layers currently in the
map, which should just be the 2 basemaps. On the right, you will see the Catalog pane. This is where you can
access everything associated with this project, including GIS data, saved maps, project toolboxes, etc. Double
click on Folders and you will see your connection to the ArcGIS_Basics_India Folder in Tufts Box.
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Downloading the GIS Data
1. Now, we need to download the data that you will use for this exercise. The data is saved here:
https://tufts.box.com/v/ArcGISBasics-Somerville
2. Download this ArcGIS_Basics_SomervilleData zipped file. Depending on the browser you are using, it might ask
if you want to save, put it in the downloads bar at the bottom or save it directly into your Downloads folder.

3. In the Windows File Manager, navigate to your Downloads folder. Copy this zip folder over to your Box →
GIS_Tutorials→ArcGIS_Basics_Somerville folder and paste it there. There will be several other files in the
windows folder including the Aprx (ArcGIS pro project file) and several other folders that were created when you
started this ArcGIS project.

4. Right click on the ArcGIS_Basics_SomervilleData.zip file → 7 Zip → Extract Here. (Alternatively, you might not
have 7-zip installed so just look for Extract here or Extract All or something similar).
This unzips all the components that are contained within this GIS data folder so you can use them in ArcGIS Pro.
You should now be able to see an unzipped file called “ArcGIS_Basics_SomervilleData”. The zipped file will also
still be there, which is useful to keep as a backup in case the data somehow becomes corrupted.
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5. Now that you’ve unzipped the data, let’s work with it in ArcGIS Pro. Go back to your ArcGIS Pro project file and
on the right side in Catalog, right click on the folder “ArcGIS_Basics_Somerville” and press Refresh. This will
allow us to see any new files or folders added to our project folder.
Note: Whenever you add new files to a folder and the project is ALREADY open in ArcGIS Pro, you must refresh
the folder in order to see what has been added.

Previewing and Managing Data with Catalog
ArcCatalog is the primary way to organize and manage GIS data within ArcGIS Pro. You use it to manage your data sets
(copying, pasting, deleting, and reading metadata if available). You can view the information within the Catalog Pane, or
by opening up the Catalog View – which has slightly more functionality than just the pane on the right.
1. To view the Catalog Pane or Catalog View, click on the View Tab and then Catalog Pane. If it was not already
open, now the Catalog should open to the right of your map

2. To open the Catalog View, click on the View Tab and then Catalog View. Now, a new tab opens in the project
called Catalog. If you also have the Catalog Pane open, it might remain on the right.
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3. As mentioned, in catalog we can organize our spatial data. We can also preview the data and the attributes,
view the geography and change the file name.

Understanding and Using Folder Connections
1. On the left side of the screen, you will see a Contents Pane showing Maps, project Toolboxes, Databases, Styles,
Folders and Locaters. These are all specific to this one project.
2. If you double click on Folders, you will see any folders that we are connected to. Likely, you will only see the
folder called “ArcGIS_Basics_Somerville”. Again, this is the folder that was created when we started this project.
IF you are on a Data Lab computer, you will also see 3 folders called the H, M, S. These are specific GIS folders
that we have configured to map automatically. The M drive contains lots of GIS data and the H drive is personal
data storage for you as a Tufts student.
3. If you have GIS data in another location that you want to access, you will need to make a connection to that
folder by right clicking on the folder and selecting Add Folder Connection. For this activity, we already have all
the data we need within your project folder so no need to do this.
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Previewing Data in Catalog
1. In your Folders connections, expand the ArcGIS_Basics_Somerville folder. Inside, you will see several more
folders including a folder called MassGIS, Somerville, and a geodatabase (the cylinder) called
MassGIS_extract_Geodatabase.gdb. Click on the Somerville folder.

2. Now, in the middle, you will see all the different shapefiles within the Somerville folder.
3. Click on the first shapefile called Buildings.shp. Now, on the right you will see any metadata that exists for the
layer (which is essentially none right now).

4. You can also click on the Geography Tab and the Table tab to see a preview of the data set and the attribute
table.
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5. Catalog is helpful at letting you explore the datasets before you actually bring them into your map.
6. This Buildings dataset is called a Shapefile. This is a very common GIS data format, created by ESRI, the makers
of ArcGIS. This is very important: a shapefile actually consists of many files that work together. If you look at
this dataset using the regular Windows File Manager, you will see that is as many different files associated with
it. But when we view it in ArcGIS Pro, it just is the one file. This is why organizing, copying, deleting and
renaming files is done in Catalog and NOT windows file manager – because it updates everything together. If
you accidentally delete even just one of the components in the windows file manager, the dataset will be
corrupted and not work. So working with it in ArcGIS Pro ensures better data management.
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Reading data documentation (metadata)
1. Expand the MassGIS folder → Physical_Resources and click on the LandUse_Poly_Clip dataset. This is a data set
from the state of Massachusetts GIS Sites (hence MassGIS) showing land use polygons (e.g., residential,
commercial, agriculture). Click on the Table tab.

2. When you preview the land use data set, it is probably difficult to understand what it was supposed to be
representing. And it was impossible to understand the column headers without further information. It is critical
to have documentation about the data you are using. Data about the data is called metadata.
3. MassGIS, the statewide GIS clearinghouse, has excellent metadata online. Click here to read about the land use
data set: http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-ofgeographic-information-massgis/datalayers/lus.html
4. Look through the land use data documentation. You can use this metadata to understand:
a) Is the land use data set up to date (i.e., do you know from this data set what an area’s land use is
today)?
b) For what years is land use documented?
c) What was the source of information for determining land uses?
5. Scroll down the MassGIS land use metadata web page until you find information about the Attributes and the
codes that represent land uses. Now we know what each of the headings in the table mean!
6. Metadata is also sometimes accessible within Catalog, but only if the agency that created the data has written
metadata in a format that Catalog can read. With landuse_clip_poly still highlighted in the Catalog Tree, click on
the Metadata tab. Unfortunately, this layer doesn’t have metadata that can be read by ArcGIS Pro at the
moment.
All US Federal agencies are required to document their GIS data following a geospatial metadata standard set out by the
US government. Most state agencies will also document their GIS data, but not necessarily to the Federal standard.
Local agencies vary widely in their documentation. Some do not document their data well or at all. Metadata is critical
to data users - without it, you may not know what a particular data layer represents, when it was created, if it is
complete, what the attributes mean, or what format it is in. We will discuss the importance of metadata more in class.

Summary
Catalog is a useful way to manage your GIS data, for organizational functions like moving, copying, and renaming. It also
offers access to metadata if the source agency has put the documentation into a format that ArcGIS can read. In many
instances, you’ll find metadata online, or in a text file accompanying your data set. Sometimes, metadata may not exist
at all. It’s up to you to search for it and make sure you understand the data you are using.
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Adding GIS Data to your Map
1. Alright – time to do some actual mapping! Click back on the Map Tab to get back to the map.

2. In the Catalog Pane (on the right, now the separate tab we were just in) double click on the
ArcGIS_Basics_Somerville folder and then double click on the ArcGIS_Basics_IndiaTutoial folder. Expand the
folder for MassGIS → Physical_Resources.
3. Click and hold on the Hydro25k_poly_clip file and drag it into your ArcGIS Pro window – after it draws, take a
look at it – what does it seem to represent? Here is the link to the MassGIS Metadata:
https://docs.digital.mass.gov/dataset/massgis-data-massdep-hydrography-125000
Take note of what each shapefile looks like when you add it to the map. Are they points, lines or polygons? Look
at the icons in Catalog, that will also give you a hint!
4. Drag Hydro25k_arc_clip into your ArcGIS Pro window – what does this represent? How is it different than the
other layer we just pulled in?
5. Expand the folder for Somerville. Pull in all the Shapefiles in the Somerville folder.

6. Your map is a bit of a mess with all these layers! We need to organize!
7. To the left of the screen in the Contents pane, underneath “Drawing Order”, order the layers by dragging them
into place. You want the largest polygon layer, the City_boundary layer on the bottom. Then the next largest
and so forth. Layers draw in the order they are listed in the Contents pane. Usually, you want them to be Points,
Lines and then Polygons. Drag the layers into place so they are in the following order:
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8. Turn all the layers off. Then, one by one, turn on and off each layer so you can see what just that layer looks like.
Also, notice your colors are probably different than mine. That is because there is no default color when you first
bring layers in…its totally random until you set it.
9. Once you’re done looking at the layers, turn off (uncheck) all of the data layers except for street centerlines
(Streetscl), hydro25k_poly_clip, and parks. They should remain listed in the Contents Pane but should not be
visible in the map view.

Getting around the Map
1. Click on the Map tab at the top of ArcGIS Pro.

2. The Explore button allows you to move (or pan) the map by left clicking on your mouse. You can also zoom in
and out using the mouse scroll wheel. If you click on data in the map, a pop-up will appear of their attributes so
you can learn more about that particular point, line or polygon.
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3. Select the Explore tool and try clicking on water, parks and streets. This highlights the polygon, line, or point
depending on the data and brings up information from the “attribute table” for each feature you click on.
4. Zoom into Somerville using the mouse scroll wheel and hovering your cursor over the town. You can also hold
down shift and with your mouse, draw a box around Somerville to zoom directly to that extent.
5. Additionally, you can Zoom In and Zoom Out using the fixed zoom in and fixed zoom out tools. You can return to
the previous extent you were at on the map using these arrows:

6. Use the Zoom to Full Extent tool to go back to the full view of your largest dataset (in this case it zooms to the
world since the basemap is on).

Note: In ArcGIS, you can place the cursor over each tool in the menu without clicking to see a description of
what it does. Hover over the Explore icon and try out some of the shortcuts.

6. Can you find Professors Row on the Tufts University Campus? Click on the Locate icon (
) on the top toolbar
and type in Professors Row in the search bar. A list of results will be provided, click on the option where it says
Medford, MA.
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7. You’ll be brought to this specific location. You may have to zoom out your map view to see the full extent of the
street and its relative location. You can also right-click on a result and get different options like Zoom to and Pan
to. Close the Locate Pane by clicking on the X in the top right corner.

7. When you are done looking around, right click on the CityBoundary layer back in your Contents Pane and select
Zoom to Layer. This is another way to zoom to a specific scale/layer.
8. ArcGIS Pro makes it really easy to quickly change the basemap. Try out different basemaps to see what you like
most.
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9. Take a minute to look through the other Tabs up top. The Map tab has a lot of basic tools for getting around the
map and working with the data. The Insert tab has options for adding new maps, new layouts and notes to the
map. We will work with this tab later. The Analysis tab has many different tools and toolboxes. We won’t really
get into this in this tutorial. The View tab lets us view many of the different panes (if we accidentally close
Catalog or Contents, etc). The Edit tab lets us direct edit the data (we won’t do this either). Imagery lets us work
with lots of raster data and imagery data. Finally, the Share tab is how we save and share out our maps or
upload them online.

10.
11. Now choose Project → Save. You have already created a project file name for this
(ArcGIS_Basics_Somerville.aprx). A project file is a very small file that contains pointers to your data sets – it
does not actually save the datasets, just where to look for the data upon opening your ArcGIS Pro project. The
aprx project file remembers what you had displayed in your map session and how you had it styled, along with
how far you were zoomed in/out. If you quit ArcGIS Pro at this point, you can reopen this map .aprx file by
double clicking on it in wherever you have saved in (in my case Box) and everything will be as you left it. Thus,
project files are easy ways to save work and get right back to where you left off.

But beware –since project files do not actually contain data layers, and only have pointers to where the data is
saved, if you copied your ArcGIS_Basics_Somerville.aprx file and tried to open it on a home computer without
also copying/moving the shapefiles, the ArcGIS Pro session would start and list the data in the table of contents,
but nothing would appear because it would not be able to find the where the data is stored. A little red
exclamation point would appear in the table of contents, informing you that it has lost the connection to the
data.
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12. Save your project file frequently and always save at the end of a session. ArcGIS Pro likes to crash! For reals!!

Defining the Layer Names and Basic Symbology
In this section of the tutorial, you will learn how to organize your data layers' properties to start bringing some
coherence to the map. You will also learn how to symbolize your data to assign colors to each layer so that it starts to
make sense and be intuitive to the reader.

Assigning proper layer names
First, you need to give the data layers better names than what they have (e.g., Streetcl is what we call “data speak”. It
should say Streets)
1. Right click on the Streetscl layer and choose Properties (alternatively, you can double-click on the data layer
name SLOWLY).
2. When you see the Properties dialog box, click on the General tab. In the Layer Name box, type in Streets instead
of streetscl. Press OK when finished.

Note: this does not change the name of the original data set - it only changes the name as it appears in this
session of ArcGIS Pro and as it will appear on your final map. If you went back to Catalog, streetscl would still be
the name used.
3. Give all the other layers more coherent names as best as you can (e.g. “City Boundary” instead of CityBoundary,
“Water Bodies” instead of hydro25k_poly_clip). In the future, points will be deducted on assignments for having
non-standard English "data-speak" names like "streetscl" appearing in your map.

Assigning proper colors with Symbology
Your map would be a lot better if the water were colored blue, the parks green, etc.
1. Turn on and click on the Water Bodies layer. Notice how when you click the layer name, 3 new tabs appear at
the top. ArcGIS Pro is contextual (like Microsoft products). When you click on layers, more options usually
appear to work with that layer.
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2. Click on the Appearance tab and then click on Symbology. A new Symbology Pane appears on the right where
Catalog was. Symbology is where we set colors for layers.
3. To change the color of the layer, click on the colored box next to Symbol. This should bring up a Gallery of some
default options to choose from – choose a blue color for water.

This water option is nice because it doesn’t have any outlines (which is useful for natural features). If you want
to choose a different blue, you can click on the Properties tab and adjust the color further. Click Apply.
4. Turn on the Parks layer and use the same process as above to color the Parks layer green. Note: You can quickly
get to the symbology by clicking on the square under the layer in the Contents pane.

5. Turn on the Buildings and color them a light gray. Make sure there’s no outline for the symbol otherwise some
buildings will appear black if they are small. You can turn the outlines off by going to the Properties tab. Then
click on the small box just right of Outline Color, and choose No Color. Another way to do this is by changing the
outline width to 0 pt. Click Apply.
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6. Turn on the neighborhoods layer and go to its symbology properties. Use the “No Color” fill so it’s see through
and make the outline width thicker (e.g., 2) as shown below:

7. Drag the Neighborhoods layer to the top of the Table of Contents. Since it’s see through now, it can go on the
top.
8. Using what you have learned about Symbology, give appropriate colors to your other layers, with the exception
of the Parcels layer.
A tip for coloring roads: The road centerlines, at least for non-major roads, often look best in a map if they are
colored a light gray or white (depending on how dark your city boundary is). That way they show up but won't
dominate the map.

Labeling a Layer Based on an Attribute Field
You can label features based on data in the attribute values. Let’s label the States.
1. Click on the Neighborhoods layer again and now go to the Labeling Tab.
2. Click on Label and make sure the field is set to HOOD_NAME. This will pull the info from the attribute table in
the “HOOD_NAME” column – aka the neighborhood names.
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3. Now, let’s improve the Labeling format. In the Labeling tab, try a couple of the premade label styles to see how
they look.
4. When you’re done, select the POI (White Halo). This is nice because it automatically puts on a “halo” around the
text so it pops against the background and gives a bit of character spacing.
5. But, they’re a bit small. Adjust the font so it is Bold and adjust the font size up to 11 or 12 (depending on your
screen size) and make sure you are zoom all the way into Somerville (and your ArcGIS Pro session takes up your
full screen). The bigger the map, the more detail you can see without it being crammed.

6. There, now they look pretty nice!
7. When finished, choose File →Save again. Now your project file will remember all the colors and names you have
assigned. It's starting to look better....
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Using Symbology to Map a Layer Based on an Attribute Value (land use codes)
It would be useful if you could distinguish between types of features within in the same layer. The Parcels layer, for
example, shows property boundaries but doesn’t give us more information about the type of property when drawn with
a single color. You can use an attribute field to symbolize your data to reflect the field values.
1. Turn on the Parcels layer so it is visible. Zoom in to a Neighborhood to see what the parcel data looks like.
Parcels are the property boundaries and the data contains a lot of information on the owner, address, type of
property, etc. Here, I zoomed into Tufts and I can see the parcel (property) boundaries, along with the building
footprints on top of the parcels.

2. Open up the Attribute Table for the Parcels layer by right-clicking on the Parcels layer in the contents pane and
choosing Attribute Table.
3. The Attribute Table is VERY important in GIS and often times you will symbologize a field within the attribute
table. When you’re just starting off with a layer, it’s very useful to explore what is in the attribute table.
4. Click on one of the rows (on the left side of the table). It will “select” that parcel in the table and in the map. If
you double click on it, it will zoom to that particular parcel feature.
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5. Scroll across the table to see all the different column headers and information in the table.
Suppose we want to color parcels by their major type of use (e.g., commercial, residential). The attribute table
contains relevant information in this regard, but unfortunately, we have no metadata to explain each attribute
column. In order to know what fields might be useful to color (symbologize), you must be familiar with the
attribute table structure, its fields, and the possible values of each significant field. Sometimes this can get
confusing because there may be many fields, and the values in those fields are codes with which you are not
familiar. This is when metadata becomes very important. Without metadata, you are stuck trying to track down
this kind of important information about the data set. Sometimes, however we can figure out what some of the
fields represent without metadata.
6. Scroll until you see the Use_descri field. What might you guess this stands for? If you guessed “Use Description”,
you’d be right. Scroll down to see the different types of values within this Column (like Sing Famly; Two Famly,
etc)
7. Look to the right of the Use_descri column and you will see a CLS column. Look at the values in the CLS column
and compare them with the Use_description column. What do you think the CLS values represent?
8. Right-click on the CLS name at the top of the column and choose Sort Ascending as shown below:

9. Scroll through the values, comparing them to Use Description – is it any clearer what the R, C, I, and E
represent? Note: there will be several records of “Null” values to initially scroll through.
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10. Close the attribute table.
11. Clear any selection you might have made by clicking on the Clear icon at the top. Whenever it is grayed out, it
means nothing is selected at the moment.
12. Zoom back to the full scale of Somerville (right click on the layer and click “Zoom to layer”) and turn off the
buildings layer, so we can see the parcel data more clearly.

13. Click on the Parcels layer in the Contents Pane. Then click on the Appearance tab.
14. Click on the down arrow under Symbology and select Unique Values. This is the option you will use when you
want to map Categorical (qualitative) data.

15. The symbology tab will open on the right side of your screen. From the pull-down menu under “Field 1,” select
Use_descri. Each unique value in the Use_descri attribute table field will appear with its own color. Your dialog
box should look something like this:
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This way of coloring by land use is interesting, but there are far more uses than there are colors, so you can’t
really tell which parcel has which use. This is NOT a good way to communicate land use data because there is
just too much info being mapped! What might be a better way to visualize land uses?
16. Fortunately, there is a more generalized land use attribute field in the Parcels data layer, as you saw earlier – the
CLS field. Looking at the attribute table, and knowing something about parcel assessment and planning, we will
surmise that the codes are as shown in the table below. The planning profession also has some generally
acceptable color standards for visualizing land use that we provide here (see the APA’s Land Base Classification
System Level 1 Color Standards for the official recommendations from the American Planning Association):
Code and Use

Standard Land Use Color

R – Residential

yellow

C – Commercial

red

I – Industrial

purple

E – Exempt (meaning the landowners do not pay property taxes,
indicating government, educational, religious, or other tax-exempt
civic use)

blue

17. In symbology, now change the Field 1 to CLS so we are now mapping the land use code.
18. Choose each color so it matches the standard color outlined above. Change the name of the label by double
clicking in the label text box and writing in the full word so the viewer understands. Also, change the name of
the layer “heading” to Land Use. See the graphic below:
Choose the color by double clicking on the colored square. It will bring you to the color properties. Choose the
color and then click the back arrow to get back to the main symbology.
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Note that there is a blank row. That’s because when we chose “add all values” for the CLS field, the software
found a lot of blank values. We don’t know what they are, so label them Unknown and make them grey.
19. You can move the classes around (e.g., to make Residential come first, etc.) by highlighting the class (e.g., R) and
using the arrow keys to the top right to move it up or down. Move the Unknown category to the bottom.

20. Remove “All other values”, so that does not appear in your Contents Pane or Legend. To do this, click on More
on the top part of the value box and uncheck Show all other values.

21. See how this has updated over in the Contents pane. Looking much better!
22. As you can see, it takes a lot of time to set up the data to be colored and labeled appropriately. Save your
project again at this point (File → Save) and if you quit now, you would be able to get back to your map session
again very quickly, including all your colors and labels.
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Repairing a Broken Data Link
Layer files are special GIS files that contain formatting (color, labels, etc.) for a particular data set. There are two good
examples of layer files created by the folks at MassGIS for major roads and railroads. However, the link to the original
dataset is broken…so we will learn how to fix that.
1. Open the Catalog pane. It is likely a tab at the bottom of the right pane where symbology might still be open. Or
get to it by clicking on the View tab and then Catalog Pane.

2. Expand the MassGIS folder and then Infrastructure. Drag in the EOT_MajorRoads_Class.lyr and the
Railroads_by_Service_Type.lyr. Notice how the icon for layer files (.lyr) look different than shapefiles (.shp)

3. You’ll see a red exclamation mark (!) by Major Roads and by in the Contents Pane. This means that the layer file
cannot find the actual data source (for the major roads, this is the EOTMAJROADS_clip shape file). layer (.lyr) file
cannot exist without its source shapefile!

4. To repair this broken link, click on the red exclamation mark. This brings up a Change Data Source dialog box.
Now, we need to tell it what is the original shapefile source for this layer.

24

Tufts University Data Lab
5. In that dialog box, double click on Folders → ArcGIS_Basics_Somerville → MassGIS→ Infrastructure and then
click on EOTMAJROADS_clip.shp. Then press OK.

6. Now, the layer has been repaired and it works! Turn it on if you haven’t and see how MassGIS has presymbologized the layer for use in GIS. Pull it to the top of the contents, right under the neighborhoods layer.
You’ll see that these layer includes colors, line styles, and labels, including highway shields for the interstate and
state routes, and different railroad symbols depending on the current status of the track. These were set by the
staff at MassGIS and saved as layer files to accompany the GIS data sets. You can have many layer files for one
GIS file, displaying the same GIS data in different ways (for example, you could display parcels to show land use
or to show land value).
7. Save your project.

Measuring features and Drawing a Map at Scale
Making measurements and scaled maps is a very important GIS function.
1. Click on the Measure tool under the Map tab on the top.

2. Click somewhere on the map to start a measuring line. Drag the line somewhere else and click again. You will
see two measurements reported in the Measurement window. The first, segment, gives the distance (in feet) of
the line you just drew. The second, Path, gives the total distance. Click on a third point in the map. You will see
the new segment distance plus the total distance of both segments. Double-click on the map to stop measuring
(or choose a different tool).
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3. If you want to measure in a different unit, click on the little black triangle as shown below and select a new
distance unit:

4. Try calculating the area in acres of the Somerville section of the Tufts campus (turn on the buildings to help
guide you) – use the polygon tool in Measure as shown below and set the area units to acres:

Hint: If you want to measure a new area or length, close the measure tool and open it again.
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Drawing a map at a set scale
Many professional map users expect printed maps to be at a standardized scale. USGS topographic maps are printed at
1:100,000 scale (1 inch on the map equals 100,000 inches in the real world or about 1.58 miles) and at 1:24,000 scale for
example (1 inch on the map equals 24,000 inches in the real world, or 2000 feet or about 0.38 miles). In ArcGIS you can
scale your map to any scale, but you are also offered standard scales from which to choose.
1. You can set the scale at the bottom of the Data Frame. There are several set scales available, or you can type in
your own.

2. Set the scale of your map to 1:24,000. This is a typical scale for mapping a city.
3. Experiment with some of the other map scales. Which scale would be good for a detailed map of East
Somerville or the Tufts campus? What about for a study of transportation in metropolitan Boston?
4. Try typing in 12000 in the scale box – this creates a map at 1:12,000 scale (1 inch on the map equals 12,000
inches in the real world, or 1000 feet).
It’s important to start becoming familiar with map scales. You have been using what is called a unitless scale – e.g.,
1:24,000 means 1 of any unit on the map (inches, centimeters, feet) equals 24,000 of those same units in the real world.

Making data layers transparent
Suppose you wanted to show land use by category over aerial imagery. You can display layers above the aerial imagery
or shaded relief to be somewhat transparent if you like.
1. On the Map tab, change the Basemap to Imagery.
2. Turn OFF all layers EXCEPT the parcels (symbologized by Land use), Neighborhoods, Parks and Water Bodies.
3. Zoom into Davis Square, Tufts University or Union Square. Whichever you would like to examine.
4. Click on the parcels layer and go to Appearance tab.
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5. Set the Transparency entry to 50% and press OK to see what happens (it may take a while to draw).
Note: You can also use the slider to the right of the box to change the transparency.

6. When you’re done experimenting, save your map file again.

Creating a map for printing or exporting as a digital graphic
Now that all our data is mapped and symbologized, it’s time to make a map! It is important in a map not to include too
much information so that map is illegible.
In order to create a printable map, you will add a new layout to the project. A layout is a paper view of your data, much
like viewing the page layout when you are working in a word processing software. In ArcGIS Pro, you can add multiple
layouts to a project!
For this activity, you will create a map of a Neighborhood in Somerville, such as Davis Square or Union Square.
When you create a map, it should include:
•
•
•
•
•
•
•
•
•
•

The map itself, duh
A descriptive title, including key location and dates
A legend – No data speak. All colors, symbols and numbers formatted nicely
A scale bar (with appropriate units and sized well)
A north arrow
Cartographer information (name, date, class)
Data Sources
Any annotation you might want to include about the map (optional)
Labels (optional)
Locator Map (optional)

It is important in a map not to include too much information. You would not want a map that includes all the data layers
you have in your ArcGIS Pro session from this tutorial. It would be much better to do several maps, e.g., one showing the
general layout of Somerville with streets and parks, another showing land use, possibly one showing the buildings in
black with all the other space blank (this is called a Nolli map by urban designers and is used to explore a community’s
built fabric).
You may also include other elements on your map, for example, more explanatory text, charts, tables, photos, or other
images.

Setting up a Map Layout
1. Before you start a map layout, it is important to think through what you want to do and how you want your map
to look. What do you want to show? How large do you want your final map to be? Portrait or landscape
orientation? Do you need space for additional text or graphics? This tutorial example will assume a printer
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paper size (8.5x11 inch) map but often you are making map for publications where they must be smaller, or for
PowerPoint where they need to be a certain size (e.g., 7.5x10 inches), or for posters where they may be much
larger than 8.5x11.
2. Click the Insert Tab → New Layout. In the dropdown menu, select Letter (8.5” X11”).

3. This will open up a new window called “Layout” on a new tab. To get back to your map, you can click the Map
tab. But for now, you’ll want to work in this Layout tab. Notice how the top toolbar now has different options for
adding map elements.
Note: if your layout opens in a split screen view with your map, you can click on the title tab that says layout
(highlighted in red below) and drag it up to the map tab. When the map tab is highlighted in blue, release and
your layout tab will be next to your map tab like in the screenshot below.

4. Now, we need to place our Map on this piece of paper. To do so, click on the Insert tab and then Map Frame
and select the image of our map. Draw a box where you want the map to be placed on the paper. Make it
ALMOST as big as the paper, leaving a little border for “printable margins”. I am also going to leave about 2
inches of space at the bottom for map elements (Locator Map, Title, Legend, etc). The data frame map
placement is a big part of the overall page design. It is ok to put map elements in the map itself or put them
outside the Data Frame as I will do in this example.

29

Tufts University Data Lab

5.

You can adjust the size of the Map Frame using the vertices on the corners of the map.

6. On the left under Contents, click the down arrow to expand the Map Frame. Now you can see all the layers in
this map and turn them on and off. In this example, we are going to map the Land Use by Parcels so turn off any
layers that are not needed to make this final map. Keep on Neighborhoods and if you want, you can keep on
the Water Bodies as well.

The Layout Toolbar
It is very important to understand the difference between being in a Layout vs a regular Map. When you are in a Layout,
there are a lot of similar tools in the Layout (zoom in and out, pan) but the Layout tools work on the layout as if you
were zooming in and out of the paper itself), while the same tools on the Map toolbar work on the data inside the data
frame (e.g., zoom into Madagascar).
1. Take a minute to look in the Layout Tab to see the tools, hovering over the tools to see what they do in the
Layout Tab.
The Map Toolbar

The Layout Toolbar
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2. The navigate icon allows you to move the piece of paper. The full extent icon
view. The 1:1 tool
(100%).

zooms so the whole page is in

is particularly useful to see what the map features and text looks like at actual print size

3. See what the other tools in the Layout tab do as well. Orientation would allow you to change the page
orientation quickly and painlessly.
4. Moving and re-sizing the map or any map element works similarly to most other programs. The key is selecting
the element first. Once you do that, you can use the vertices to resize anything or move the map element.
5. Now it’s time to position the actual data within our Map. Your data might not be at the scale you want it for
print or at the right spot.
6. In order to move the position of the data within the map, we need to Activate the data frame. In the Layout
Tab, click Activate to be able to interact with the map and zoom in/out and pan around.
Note: You can also right click to activate the map.

Notice how the toolbar switches back to the map tools used for mapping and analysis. Now, you can use the
Explore tools to zoom and move around Somerville. Hold down shift and draw a box around the data you’re
mapping. Then use the explore again to position your data how you want it on the page.

7. Once your map and data is in the place you want it, you can deactivate the map by clicking on the Layout tab
and then Close Activation. This will lock the data in place and bring us back to the layout tools. See examples
below for India Map.

8. This is how my map currently looks for Davis Square. Also, if you are using a basemap that has any labels – make
sure to turn off the “reference” layer so the labels are not on. We will only use our labels.
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Adding a Second Data Frame to Show a Locator Inset Map
You can add a second (or more) data frame to your Layout. This can be handy for putting in a small "locator" map that
shows the location of your main map in a greater context. See the following graphic:

Multiple data frames can get a little tricky and will take some practice. But we want to get this done before adding all
the other map elements (like a title, legend, etc) so we don’t have to rearrange everything after.
1. In Layout View, choose Insert → New Map from the top main menu. A blank new map will appear on the top
tab. Click on this new tab and rename the data frame to Inset Map by clicking on the Data Frame in Drawing
Order twice slowly.
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2. Since we’re making a map of a specific neighborhood, the scale of our locator inset map should be all of
Somerville, or even the greater Somerville area. Locator maps are always relative to the scale of the main map. If
I was making a map of Somerville, I’d likely want my locator map to be all of Mass – so I can see where
Somerville is located within Mass. This is what we mean when we say it’s relative.
3. Now, we will need to add data to this new map to create the Locator map. Open Catalog on the right and
expand the MassGIS Folder → Political_Boundaries and drag in the TOWNS_POLYM.shp shapefile. This will
zoom us to Massachusetts and we can now see all towns.
4. Find Somerville, located in greater Boston! If you don’t know what it looks like, you can use the Explore tool to
click on the towns, which will pull up their attributes. Alternatively, you could open the attribute table, find
Somerville and double click on the row – which would zoom us to Somerville.
5. Zoom into Somerville. Set the symbology so the towns are see through with an outline of 1.5. We can further
adjust the styling if necessary when we are making the locator map on the layout.
6. Go back to your layout view of your final map.

7. Click on the Insert tab then on Map Frame. Select your new map and draw a smaller box in the blank space at
the bottom or in one of the corners where it fits nicely.

33

Tufts University Data Lab

8. You’ll now likely need to adjust the zoom and position (and perhaps the size of the Frame). Click on this new
map and then in the Layout Tab, click Activate.
9. Zoom in to Somerville and center the map. If needed, adjust the size of the data frame by closing the map
activation and moving it with the vertices. Don’t worry about the annoying citation. We’ll get rid of that in a
little.

Setting up Locator Extent Indicator Bounding Box
We’ll now need to identify where our main map is within our small map of Somerville. We will do this using an Extent
Indicator bounding box. This is useful when you’re zoomed into an area that isn’t necessarily it’s own shapefile.
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1. Insert the 2nd Data Frame in your layout as directed above and make sure the zoom is set to Somerville. Close
the map activation when done setting the zoom and placement.

2. Click on your inset map using the select tool (

) to it’s selected (aka you can see the vertices).

3. Go to the Insert tab and select Extent Indicator in Map Frames group. This adds a box to your inset map
showing the location of your main map within the locator map. Now the area around Davis Square is clear.

4. You can change the size and color of your extent indicator. Notice how now an “extent indicator” has been
added to the Contents Pane. Right-click on the extent indicator layer and select Properties.

5. In the new panel on the right, make sure the source is set to the original Map Frame (just known as “Map
Frame” here). Click on the boxed symbol and go to Properties to change the outline width and color (perhaps
choosing a color that is used within your main map for cohesion and making the line a little thicker). Press
Apply.
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6. Voila! Almost done, I swear! If you want to adjust the colors in your locator map (such as the towns layer or
even the basemap), you can click activate the map and adjust the symbology within this small map.

Removing the Base Map Citations
If you are using a streaming base map, there is likely an annoying citation in the bottom right corner (of both the locator
map and perhaps even your main map).
1. To remove the citation, click on the either map. Go to Insert → Dynamic Text → Service layer credits.

2. Draw a square in the map and the text will move there…
3. Then just moveeeee it off the piece of paper lol. You can’t delete it, it will just go back to the corner. But if we
move it off the piece of paper…voila, no more annoying citation text.
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Inserting a Title
1. To insert various map elements (like the title, legend, north arrow, scale bar, etc), click on the Insert Tab. Look
over all the icons to see what you can insert here. There are lots of options.
Note: if you don’t see this tab, make sure you have closed out of the map activation.

2. Let’s start with the Title. In the Graphics and Text box, there are lots of ways to add text. Click the big A to add
straight text and click in the map where you want the title to go.

3. Type in a title that is descriptive of what we you mapping, including the variable being mapped, any relevant
dates and locations.
4. To adjust the size and alignment, click on the title text in the map and a Text Format tab will appear. You can
adjust the font, color, and size of the text here.

5. If you need to adjust where the text breaks onto the next line, click on the little icon in the corner of the text
symbol box. This will bring up more settings on the right.

6. On the right pane, you can also click on Text Symbol for more text formatting options like alignment, character
spacing, etc.
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7. Type in your title. Sometimes it is also helpful to have more info, like the location and dates, in subtitle that is a
little smaller. This helps promote the visual hierarchy. What is the location of your map? And what is the data of
the data we are mapping? (Look at the title of the layer, it might have a hint). You can add this info with a 2nd
text box.
8. Make the title pretty large so it catches the readers eye first (visual hierarchy). Take time picking appropriate
fonts and stylizing it nicely. Don’t just accept defaults, I hate that and will take points off for it later. Making
maps is as much of an art as it is a science!
9. If you are putting the title directly on your map data, you might want to add a background so it’s a bit easier to
read the text. To do so, you would add a rectangle and move it behind the text. On the insert tab, click the
rectangle and draw a square around your text.

10. Now, a Rectangle Format Tab pops up. Here, you can select a Fill and a Stroke (outline) color if you wish. You
can also adjust the transparency in the fill. I am going to make the background white, with no outline, and
slightly transparent. To adjust transparency, in the Fill → color properties, there is the options to adjust
transparency.
11. You might notice that now the box is ON TOP of the text covering it. Just like with layers in the map, the map
elements are layered in the order they are listed in the Contents pane. Move the Text above the Rectangle in
the contents. You can also turn the map elements on and off here too and you can lock them in place so that
they can’t accidentally be edited.

38

Tufts University Data Lab

12. Now, our title is looking good. Nice and big and really pops. Here is an example of the title underneath the map
and another example of the title on the map with the background. This is your design choice.

Inserting a North Arrow and Scale Bar
These are all required elements on all maps. You access them by going to the Insert tab,
1. First, click on your main map so that is selected. You want to add in the scalebar and north arrow specifically for
that map. If the locator map was selected, you would be adding the scale bar for that map instead. So it’s
important to have the main map selected.
2. Click on the North Arrow dropdown. Select one that you like. Put it in a bottom corner, out of the way. You can
adjust the size, but don’t make it too big. If you don’t like the style, simply click once on it and press delete. Then
reinsert a different one.
3. Click on the dropdown options and pick a Scale bar that you like. Put it in the bottom corner next to the north
arrow, out of the way. If you don’t like it, simply click once on it and press delete. Then reinsert a different one.
4. In the upper menu, click on the Scale Bar Design tab, change the Number of divisions to 1 and Number of
subdivisions to 2. This takes away all the junky numbers inside the scale bar and makes it cleaner. Also, since we
are working in Somerville, the units should be in miles. Change the Division Units to Miles. Set if you want the
label position above, below, etc.
5. Make sure the scale bar doesn’t cross over onto your data. Use the edges to change the size. Also, make sure it
is rounded to a number that makes sense (aka .1, .5, 1, etc…not .67 miles). You can also adjust the label
placement, whether you want it on the right, below, above, etc.

6. Again, notice how in the Contents window there are now “layers” for Text, North Arrow and Scalebar. You can
now turn them on and off, as if they are a layer. You can also click on the little lock, to lock the style in place so
they can’t accidentally be moved, edited, or deleted.
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Inserting a Legend
Now, onto the legend, which is the trickiest part.
1. Click on the Insert tab and then Legend. Draw a box where you want the legend to be placed. Click on the
corner vertices to adjust the size and placement.

2. Click on the new Legend tab and choose a font. We’ll adjust font size separately later.
3. In the contents pane, notice how a legend has been added and if you expand it, you can see all the layers. These
will be the layers that are on in the legend. Uncheck everything except the layers on in your map (parcels and
Neighborhoods). Turning them off in the legend won’t actually turn them off in the map though.
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4. If there is any data speak in your legend (underscores, all caps, etc), that needs to be cleaned up on the actual
layer itself (under the Map Frame section) and not in the legend. For example, the Parcels2004 Layer Name has
data speak. The Heading, “Land Use”, looks good because we edited that when we were setting the symbology.
5. In the contents pane, scroll down until you find to the Map Frame section and then find the layer for
Parcels2004. Click twice on the name SLOWLY which will open the text box. Change it to just say Parcels. Check
the Neighborhoods layer and make sure that looks lice (no dataspeak, N is capital). Adjust as necessary. If you
have the water polygon on, change the name from Hydo25k to Water Bodies.

6. Cleaning up the layer names cleaned up the legend a lot. But we still need to fix some things. For example,
Neighborhoods should be underneath the Parcels layer in the legend because it would look better visually and it
is not the main point of the map.

7. To move Neighborhoods underneath the Land Use layer IN THE LEGEND (not actually in the map), scroll back up
to the “legend” in the contents pane. Then drag Neighborhoods under Parcels. You can move the order of layers
in the legend this way. Much better.
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8. The size of the font actually looks pretty good. But if you wanted to adjust the font sizes/emphasis for the layer
names, headings and labels, right click on Legend and click Properties. This will bring up more options on the
right to all the legend contents.

9. On the right pane, click on the 3rd icon “Display”. Here, we can assign a background color and border style to the
legend if you would like. If your legend is on top of your map, this is probably a good idea. If your legend is in the
blank area BELOW your map, this is not necessary.

10. Next, while Legend is highlighted, click on Text Symbol and then change the drop down to Layer Names. Now,
we can adjust the size and fonts for JUST the layer names. I am going to choose the matching font from my title
and make them bold and size 16. Click Apply to see changes.
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11. Now, change the drop down to “headings”. This will edit the style of the text underneath the layer name. I’m
going to make this bold and size 14. That way, they are slightly smaller than the layer titles.
12. Lastly, change the drop down to “labels”. This will edit the style of the text next to the symbols. I’m going to
make this regular and size 12 with the matching font. That way, it is smaller than both the layer titles/headings
and has different emphasis.
13. Now the legend looks nice, with appropriate size text and formatting.

Play around in the other legend options to see what happens.

Insert Cartographer Information, Data Sources, and any other Annotation
1. You will use the Insert tab again to insert your cartographer information. Click the A to insert a text box.
2. Add your name, class info and today’s date and put it somewhere that is out of the way but makes sense.
3. Again, click on the Text tab to adjust the style of your Cartographer info. Edit the font, size, alignment, position,
etc. Open the Text Symbol properties for further adjustment if necessary.
4. Add another text box for Data Sources (or you could put this in the same text box as your cartographer info if that
makes sense). This data came from MassGIS.
5. You could also use this to add any annotation for the map, such as any further explanation of the legend or
perhaps an explanation of what the map is showing.
6. If you want, put a background behind the text like we did for the title.
7. Look over all the other map element placement. Now that you have all necessary elements included, adjust the
positioning of each so they are aligned nicely, and the best size and position relative to all the other map
elements. Once the map looks good, you’re ready to export!

Exporting your Paper Map
When your map layout is perfect (or good enough, ha), you will need to export your map to a digital graphic format (aka
an image) like .pdf, .jpegs, .png or .gif.
1. When you have your layout the way you want it, on the top menu, choose Share tab → Layout Export.

2. In the Export dialog box that appears on the right, navigate to where you want to save it. In this case, I will save
it in the same box folder I have been saving everything. Give the image a descriptive name such as
DavisSquare_LandUse _Map (remember, no spaces!).
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3. For Save as Type, choose a format - we recommend png, .gif, .jpeg, or .pdf because they come out well and are
readable across a variety of platforms. I am going to use a .png.

4. Before you export, adjust resolution under the Resolution (DPI) area. Digital images meant to be seen on a
computer screen do not need high resolution. Change the resolution to 300, which should be the maximum.
5. Press Export when you are ready to go - the process will take a minute.
6. Check your results by navigating to the windows folder outside of ArcGIS and opening the graphic - if you’re not
pleased, experiment with different resolutions and compare file sizes.
7. Once you have created one map in a layout you like, save the project file. That way you can return to it later if
you need to change something.
Check out my example map at the end of this tutorial.
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